Jump to content


M18C: First couple shot problems...

M18C + fresh mag problems

  • Please log in to reply
2 replies to this topic

#1 thatguyx

thatguyx

    Enthusiast

  • Members
  • PipPip
  • 89 posts
  • Gender:Male
  • Location:Edison, NJ
  • Country:

Posted 31 October 2012 - 02:11 PM

I recently rebuilt an M18c.  I replaced both R/L sears, impact hammer with a shooters design impact hammer, kwa full auto hammer, and a guarder upgraded hammer spring.  It's also sitting in a Pro-Arms OD frame, which seems to be a little loose on the hammer housing.  When I pull the trigger I can see the hammer housing move ~1mm.  I've since wedged a piece of card stock in there to tighten things up; no more movement.  The hammer housing and trigger transfer bar are used, but appear to be functioning correctly.  

It's about 95% complete, but I run into some problems with a freshly filled mag.  One symptom is that pulling the trigger release the hammer, but nothing happens.  For the most part, I think that may have gone away, after I bent my hammer spring out a bit to give it a little more tension.  The second and more common symptom is that the first 2-3 shots have very little blow back. It will shoot the first bb, but not blow back hard enough to load the next.  Also the FPS will be at about 260~275fps with 0.20g  I can manually press the release valve to let some gas out and the M18C fires perfectly fine and can still finish a full mag.  FPS returns to approx 320-325fps.  

I've checked rocket valve, cylinder and sealed the cylinder pin with a little bit of super glue.  

Any ideas on how to get it to fire properly with a fresh mag?  I'm ready to order a new hammer housing and trigger trasnfer bar, but if there are any ideas before i spend money on parts it would be appreciated.  *note*I cannot send this into KWA as the slide (which is functioning perfectly in my other -ahem-18C frame), does not have an orange tip.

#2 thatguyx

thatguyx

    Enthusiast

  • Members
  • PipPip
  • 89 posts
  • Gender:Male
  • Location:Edison, NJ
  • Country:

Posted 13 December 2012 - 10:07 AM

FYI problem sorted itself out. Also you can try an upgraded hammer spring such as guarder or action.

#3 aaps59

aaps59

    Guru

  • Members
  • PipPipPipPip
  • 1,149 posts
  • Gender:Male
  • Location:New York City
  • Interests:Airsoft, photography, cars, computers.
  • Country:

Posted 13 December 2012 - 04:37 PM

Thanks for the tip!
Glad to see you were able to resolve the problem.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users