Jump to content


UBR doesn't thread onto LM4

UBR LM4

  • Please log in to reply
5 replies to this topic

#1 Rockhound117

Rockhound117

    Enthusiast

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Music, video games, and airsoft!
  • Country:

Posted 02 July 2012 - 07:20 PM

Has anyone mounted a UBR to their LM4? I have one I got used off another airsoft forum and it doesn't thread into my LM4's lower. I was previously using it on my G&P, so does that mean G&P and KWA have different threading? I could try forcing it, but I don't want to risk damaging my lower. I did find a UBR stock tube online meant for real M4's, but I don't know if that would thread on either.

Edited by Rockhound117, 02 July 2012 - 07:21 PM.


#2 badkarmaas

badkarmaas

    Specialist

  • Members
  • PipPipPip
  • 413 posts
  • Gender:Male
  • Location:Tennessee
  • Interests:Playing airsoft, guitar, snakes.
  • Country:

Posted 03 July 2012 - 05:14 AM

They use the magpul pts ubr on one of the customs of the lm4 on airsoftgi.I'm not trying to make you seem stupid, but are you turning it the right way?

#3 Rockhound117

Rockhound117

    Enthusiast

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Music, video games, and airsoft!
  • Country:

Posted 03 July 2012 - 06:43 AM

Yeah. I've installed buffer tubes before. This one only threads on halfway before it gets stuck while the original threads on smoothly like its supposed to.

#4 BoobieM4H

BoobieM4H

    Guru

  • Members
  • PipPipPipPip
  • 1,069 posts
  • Gender:Male
  • Location:SAN JOSE, CA
  • Interests:IF IT USES GREEN GAS..I MAKE IT SHOOT BETTER!
  • Country:

Posted 03 July 2012 - 12:33 PM

Is yours rs or pts? Don't know if this would make a difference..and your threads are look ok?

Sent from my DROID2

#5 Rockhound117

Rockhound117

    Enthusiast

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Music, video games, and airsoft!
  • Country:

Posted 04 July 2012 - 03:07 AM

I'm pretty sure it's an acm clone. I got it for 80 bucks of the classifiads on another forum. It fit nicely on my G&P gbbr, but not on the ka. And on that note, other G&P buffer tubes didn't thread on either, nor does the KWA buffertube thread onto the G&P.  I had to file down some of the threads on the end because it would hang up about halfway. Then I had to grind down some material on the mounting hardware similar to the mod needed to fit an ASAP. It fits nice and snug now. Very happy with it.

#6 Guest_Allizard_*

Guest_Allizard_*
  • Guests

Posted 04 July 2012 - 08:35 PM

You might want to ask Frank at ASGI, he's been doing UBR install on LM4.





Also tagged with one or more of these keywords: UBR, LM4

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users