Jump to content


LM4 with Madbull noveske RIS - Wobble


  • Please log in to reply
5 replies to this topic

#1 MultipleParadox

MultipleParadox

    Enthusiast

  • Members
  • PipPip
  • 133 posts
  • Country:

Posted 27 June 2012 - 07:00 PM

Hi all

So, looks like was a bit stupid today.
I received my LM4, previous owner installed a Madbull Noveske RIS. On it - Magpul AFG.

I wantes to swap that AFG but it was stuck like crazy ok the rail (yeah, I unbolted it completely).

So I use a rubber hammer to try and slide it down gradually.
It partially worked but stoppes a bit efore halfway, then I decides to check things a bit: RIS now wobbles up and down ... Not much, maybe a millimeter or two, but annoying enough.

So my question is, how do I fix this? Not sure how this thing is fixed on the upper. Please don't tell me I might have stripped something, unless I really did :o :S

Any input is appreciated

Thanks

#2 akiraspeedstar

akiraspeedstar

    Guru

  • Members
  • PipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Country:

Posted 27 June 2012 - 08:51 PM

I have the Madbull Noveske rail installed on my LM4, how it's held to the gun is that the barrel nut has threaded holes. You attach the barrel nut to the upper receiver, slide the rail over the barrel nut, and finally bolt the rail to the barrel nut (two on each side and two on the bottom). If it's suddenly wobbling then I'd imagine you either loosened some of the bolts or barrel nut or if worst came to worst, you just stripped the barrel nut or receiver.

Edited by akiraspeedstar, 27 June 2012 - 08:52 PM.


#3 MultipleParadox

MultipleParadox

    Enthusiast

  • Members
  • PipPip
  • 133 posts
  • Country:

Posted 28 June 2012 - 04:19 AM

Dang... I sure hope for the former...
Will try to find some videos tut on how to get there..

#4 MultipleParadox

MultipleParadox

    Enthusiast

  • Members
  • PipPip
  • 133 posts
  • Country:

Posted 28 June 2012 - 04:47 PM

Alright folks, more fear than anything else, I managed to fix things up :D

#5 akiraspeedstar

akiraspeedstar

    Guru

  • Members
  • PipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Country:

Posted 28 June 2012 - 04:51 PM

What was the issue?

#6 MultipleParadox

MultipleParadox

    Enthusiast

  • Members
  • PipPip
  • 133 posts
  • Country:

Posted 28 June 2012 - 06:24 PM

Me... XP

I disassembled the whole guacamole, turns out the bolts was not too tight and started to unscrew themselves. Tightening solved the issue...

Yeap, I do feel stupid

Edited by MultipleParadox, 28 June 2012 - 06:25 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users