Jump to content


KP45 loose magazine


  • Please log in to reply
2 replies to this topic

#1 jakobnator

jakobnator

    Newbie

  • Members
  • Pip
  • 3 posts
  • Country:

Posted 04 June 2012 - 06:05 PM

Hello, I never really have used my KWA forum account but now that I have a KP45 tac and M16 I figured I should but I have been having a few problems with my kp45 tac (NS2 not licensed by HK). Nothing that stops the gun from shooting just inconvenient I completely re-lubed the upper slide and it fixed most of the problems but  anyways here are the problems....

1. There is about a 1mm gap of where the magazine comes out of the gun if your hand isnt holding it in place. It has a small amount of wiggle if you shake the gun up and down, normally I wouldn't care but the gun has about a 50% chance of feeding unless you have your hand fully pressed up against the mag. I tried putting electrical tape around the mag for some friction but it still comes loose and is just harder to pull out of the magwell. Any quick fixes? I don't want to buy a new magazine or, even find out its not the magazine after buying one.

Not sure about your rules on image posting but this is just an imgur photos.

Magazine w/ 1mm gap (doesn't feed) http://imgur.com/5z0nQ
Magazine w/ hand in place (feeds fine) http://imgur.com/TepKb
Where the magazine catches looks a tad worn down http://imgur.com/ZLtBl

2. Occasionally when racking the slide the piston behind the magazine (not sure what its called) sticks to where the bb is chambered this might have to do with problem #1 because it only happens when the mag is worn
Pic: http://imgur.com/LCfvb

3. Saftey is useless, when its on and you pull the trigger it goes to fire with a tad bit of give and then fires. Not sure if someone pulled to hard on it and broke it but rumor has it all you have to do is bend something back into place? I remember reading that but cant find source.
Pic: http://imgur.com/z7HzO

4. Occasionally the spring doesnt push the bb's up it just gets stuck and you have to pull the spring down and let it go hitting the bb's free from getting stuck, then it will go back to feeding I re-lubed the mag and it still happens occasionally.

5. Over playing in sandy terrain a lot of sand has gotten in the trigger/hammer mechanism if someone could tell me how to take apart the whole assembly that would be great.
Pic: http://imgur.com/tOkQC

Any help is appreciated!

#2 niko_gpsy

niko_gpsy

    What's a Warranty?

  • Super Moderator
  • PipPipPipPip
  • 5,882 posts
  • Gender:Male
  • Location:Atlanta, GA
  • Interests:Keeping those damn squirrels from putting their filthy little paws on my peaches in my backyard. Oh, Yes. It's not just a hobby, its a passion!!
  • Country:

Posted 05 June 2012 - 04:31 AM

View Postjakobnator, on 04 June 2012 - 06:05 PM, said:

Hello, I never really have used my KWA forum account but now that I have a KP45 tac and M16 I figured I should but I have been having a few problems with my kp45 tac (NS2 not licensed by HK). Nothing that stops the gun from shooting just inconvenient I completely re-lubed the upper slide and it fixed most of the problems but  anyways here are the problems....

1. There is about a 1mm gap of where the magazine comes out of the gun if your hand isnt holding it in place. It has a small amount of wiggle if you shake the gun up and down, normally I wouldn't care but the gun has about a 50% chance of feeding unless you have your hand fully pressed up against the mag. I tried putting electrical tape around the mag for some friction but it still comes loose and is just harder to pull out of the magwell. Any quick fixes? I don't want to buy a new magazine or, even find out its not the magazine after buying one.
Is this happening with a fully loaded mag?  Or same result on empty mags as well?

Not sure about your rules on image posting but this is just an imgur photos.

Magazine w/ 1mm gap (doesn't feed) http://imgur.com/5z0nQ
Magazine w/ hand in place (feeds fine) http://imgur.com/TepKb
Where the magazine catches looks a tad worn down http://imgur.com/ZLtBl

2. Occasionally when racking the slide the piston behind the magazine (not sure what its called) sticks to where the bb is chambered this might have to do with problem #1 because it only happens when the mag is worn
Pic: http://imgur.com/LCfvb
You may want to try tightening the screw under the slide towards the back.  If it comes loose it tends to cause a sticking slide.

3. Saftey is useless, when its on and you pull the trigger it goes to fire with a tad bit of give and then fires. Not sure if someone pulled to hard on it and broke it but rumor has it all you have to do is bend something back into place? I remember reading that but cant find source.
Pic: http://imgur.com/z7HzO
Working with safety is a bit tricky and you may want to send it in to KWA for repair.

4. Occasionally the spring doesnt push the bb's up it just gets stuck and you have to pull the spring down and let it go hitting the bb's free from getting stuck, then it will go back to feeding I re-lubed the mag and it still happens occasionally.
You bb channel may be dirty causing the bb follower to stick.  While the mag is empty of gas, you can remove the 2 pins located at the base of the mag.  This will allow you to access the spring and bb follower.  You can lightly sand the bb follower as well just in case it has a micro burr thats causing it to stick.  Take a Q-tip and clean the inside of the bb channel and DON't lube it.  
Sometimes just using a very highly polished bb's like KWA can resolve your issue without disassembly but still clean the bb channel for safe measure.

5. Over playing in sandy terrain a lot of sand has gotten in the trigger/hammer mechanism if someone could tell me how to take apart the whole assembly that would be great.
I wouldn't take that assembly apart unless you know your way around.  There are so many tiny parts and springs in there that you can either lose or mangle.  Try using a non-chlorinated brake cleaner solvent and tooth brush then blow it out with high pressure air.  Then relube using 100% silicone.
Pic: http://imgur.com/tOkQCI

Any help is appreciated!


#3 jakobnator

jakobnator

    Newbie

  • Members
  • Pip
  • 3 posts
  • Country:

Posted 05 June 2012 - 01:49 PM

1. It doesn't feed because the magazine doesn't stay all the way in with or without bb's.
2.Its the piston thats sticking to the hopup chamber I tightened the screw still sticks.
3.I can fix it if you tell me how.
4.Worked thanks I had to much lubricant in the feeding the oil was sticking to dirt so I just left the channel with no lubricant.
5.I tried getting stuff out of their but there is so much dirt in there I really do need to take it apart I am pretty skilled and I can take it apart and put it back together if you tell me how.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users