Jump to content


Strangely Low Fps On Usp Tactical

fps low Cylinder spring hopup bucking usp tactical

  • Please log in to reply
2 replies to this topic

#1 robski

robski

    Newbie

  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Location:UK
  • Country:

Posted 26 April 2012 - 03:34 PM

Hi KWA!

I've got a strange issue with my USP Tactical.
The mag's taken a full load of green gas with no leaking.
It's currently firing straight and semi decent kick but the fps is roughly 100/120?

I've completely dissembled the gun, checked the hop up bucking and tiny ball is secure, doesn't look swollen.

On removing the cylinder (part 135) I noticed that one of the return springs is missing, could this be the cause of the low power?

All the seals seem to be air tight, can't hear any leakage or visibly see any miss-alignments when the slides pulled back.

Everything else seems to be working, metal slide kicks, loads bb, fires just very weak.

Any ideas or info would be greatly appreciated, this has me stumped.

#2 niko_gpsy

niko_gpsy

    What's a Warranty?

  • Super Moderator
  • PipPipPipPip
  • 5,886 posts
  • Gender:Male
  • Location:Atlanta, GA
  • Interests:Keeping those damn squirrels from putting their filthy little paws on my peaches in my backyard. Oh, Yes. It's not just a hobby, its a passion!!
  • Country:

Posted 27 April 2012 - 02:16 PM

The missing cylinder return spring can cause the issues you are having.  I recommend installing a new one and report back.  If your problem persists there are other areas we can cover.

#3 robski

robski

    Newbie

  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Location:UK
  • Country:

Posted 28 April 2012 - 11:57 AM

Thanks, will look into replacing it. Will let you know how it goes.





Also tagged with one or more of these keywords: fps, low, Cylinder, spring, hopup, bucking, usp, tactical

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users