Jump to content


Mp9 Frustration


  • Please log in to reply
4 replies to this topic

#1 McDingoface

McDingoface

    Newbie

  • Members
  • Pip
  • 3 posts
  • Country:

Posted 02 April 2012 - 02:56 PM

Hi there,

Soo, my brother and I have been having some problems with the KMP9 that we own. I got it used like a year ago, and it worked fine up until the Cylinder blew up. I understand it happens. Replaced it, along with the new orange piston seal that goes with it. Since then, mysterious things have been happening. We have been scouring the forums looking for a solution, and its somewhere between a cycling issue and a jam. The gun cycles when fired, the bolt returns fine and everything, but half the time the bbs don't leave the barrel. Note that for every cycle of the bolt, a bb is loaded, but might not fire. When dry fired (I know its a sin), the gun cycles fine on both full auto and Semi auto. So, gas is coming out mag, and is properly cycling the bolt, which is loading bbs into the gun, but the gun fires intermittently. We cleaned the bucking to see if it was oil swell causing the jam, and nothin doin. Please help!!!

#2 niko_gpsy

niko_gpsy

    What's a Warranty?

  • Super Moderator
  • PipPipPipPip
  • 5,882 posts
  • Gender:Male
  • Location:Atlanta, GA
  • Interests:Keeping those damn squirrels from putting their filthy little paws on my peaches in my backyard. Oh, Yes. It's not just a hobby, its a passion!!
  • Country:

Posted 02 April 2012 - 03:00 PM

Maybe you should just change out the bucking.  It may have swelled beyond repair.

#3 McDingoface

McDingoface

    Newbie

  • Members
  • Pip
  • 3 posts
  • Country:

Posted 02 April 2012 - 03:18 PM

I was thinking this might have to be the next step in trouble shooting. Just trying to get as many opinions on it as I can before starting on the solution for it. Thanks niko

#4 McDingoface

McDingoface

    Newbie

  • Members
  • Pip
  • 3 posts
  • Country:

Posted 02 April 2012 - 03:45 PM

I found a brand new bucking. Swapped it in. Shoots fine, but found out my mags are all jank and arent feeding right. Back to the workbench to ry and stamp this one out, but should be an easy fix. Thanks again

#5 niko_gpsy

niko_gpsy

    What's a Warranty?

  • Super Moderator
  • PipPipPipPip
  • 5,882 posts
  • Gender:Male
  • Location:Atlanta, GA
  • Interests:Keeping those damn squirrels from putting their filthy little paws on my peaches in my backyard. Oh, Yes. It's not just a hobby, its a passion!!
  • Country:

Posted 02 April 2012 - 03:50 PM

Good to know. :thumbsup:
And you may just need to clean out your bb channel in the mag. Could have collected dirt over time.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users