Jump to content


I need help with my M93r


  • Please log in to reply
2 replies to this topic

#1 devw

devw

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 06 February 2009 - 07:15 PM

My M93R slide is sticking about a centimeter off from where its supposed to be, but only when the magazine is in the gun could somebody please help me it works fine without the magazine and I know it has nothing to do with the magazine because I tried two different magazines and I know they both work properly :( :angry: :blink:

#2 vietec

vietec

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 10 February 2009 - 03:52 PM

First thing is first, try to relube the gun, and see if that helps. If that doesn't work, perhaps your recoil spring is weak, in which case, you should try to stretch the spring very slowly, and be careful not to deform the spring. My gun did the same thing when I first got it, but it works fine now. You may also buy a replacement recoil spring from KWA directly. Please tell us how it turns out.

#3 XxZEITSEVExX

XxZEITSEVExX

    Newbie

  • Members
  • Pip
  • 28 posts
  • Location:91360

Posted 23 February 2009 - 07:48 PM

Well i had the same problem...its ur main piston seal. It works like an o-ring in aeg but this seal when not lubed or has lost its rigidity will be forced to the back of the cylinder. When it comes off the cylinder it doesnt allow for your slide to come completely forward- like u said it stays back a couple mm. No matter how hard u push it, it still wont budge. You have to take apart your slide to get to the chamber and put it back where it belongs and make sure it well lubed so it doesnt come off again. I have done this several times and it works great but now its definitly come to the point where i need a new one...its constantly coming off now. Hope that helps




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users