Jump to content


selector switch problem


  • Please log in to reply
2 replies to this topic

#1 ElasticShot

ElasticShot

    Newbie

  • Members
  • Pip
  • 24 posts
  • Gender:Male
  • Location:Orange County
  • Country:

Posted 20 January 2009 - 05:09 PM

Why do I have to switch to full auto then back to semi in order for semi to work? It doesnt work if I just go from safety to semi.

Now I have to go from safe>semi>auto<semi in order for it to work and I want it to be

safe > semi to work


this is for the kwa m16 and the arrows mean what goes next

#2 Guest_Radix_*

Guest_Radix_*
  • Guests

Posted 21 January 2009 - 09:14 AM

View PostElasticShot, on Jan 20 2009, 05:09 PM, said:

Why do I have to switch to full auto then back to semi in order for semi to work? It doesnt work if I just go from safety to semi.

Now I have to go from safe>semi>auto<semi in order for it to work and I want it to be

safe > semi to work


this is for the kwa m16 and the arrows mean what goes next

You have one of the few guns that may require a slight modification to the trigger cut off lever to work reliably with the latest reinforced gearbox.  Please contact our CS department for a RMA number so we can take care of it for you.  We can be reached by simply sending a email to support@kwausa.com or dialing 1-626-581-1777

#3 ElasticShot

ElasticShot

    Newbie

  • Members
  • Pip
  • 24 posts
  • Gender:Male
  • Location:Orange County
  • Country:

Posted 07 February 2009 - 01:28 AM

thanks, i had the rifle sent in. is there anyway to know when you have received the rifle?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users