Jump to content


Ns2 Magazine Issue (Pictures)


  • Please log in to reply
1 reply to this topic

#1 Traphic

Traphic

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 05 June 2011 - 06:58 PM

So I bought the M11 NS2 shortly after it was released.  Along with it two magazines.  It worked fine for a while.  After 6 months 2 magazines began to malfunction.  I put it off for a long time trying little things here and there.  Now I'm ready to get them working.  The two magazines both fire one round and the bolt stops.  And doesn't cycle back.  On occasion one of the magazines will start acting normal and cycle.  But it's random when it does it.  On the magazine that fails every time, after the first shot the magazine nozzle seal starts to pop out of place.  This only happens on one of the magazines and is shown in one of the pics below.  

I recently bought two brand new NS2 mags and realized that the Magazine nozzle seal has been improved.  It doesn't stick out as much as it is about a millimeter lower.  I'm wondering if I should just buy some new magazine nozzles here:  http://store.kwausa....mbly-1-1-2.aspx

Maybe that would solve the problem cause maybe the cycling bolt gets stuck on it?

Please help!  I can take new pictures if you need to see a part.  Also note that 3 of the 5 magazines I own work fine in the gun.  I run propane through it but I make sure everything is lubed correctly and I clean the guns and mags after every game.

Thank you

This is a picture after one round had been fired.
Posted Image


This is after one round had been fired.  
Posted Image


The left is the new model and the right is the old non-working magazine.
Posted Image

Edited by Traphic, 05 June 2011 - 07:04 PM.


#2 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,738 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 05 June 2011 - 07:31 PM

You need to replace the nozzle seal from what I see in your pics on the one that is messed up in the second picture down.  I assume that the third picture is one of the failing mags and one of the working mags...is this the case?  It also appears not to be the same as the one pictured above it?  If I am making the correct assumptions then replace the seal in both mags.  Then let us know if you have remaining problems.  :gun:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users