Jump to content


Problems With Mp9 Mag Fill-Valve


  • Please log in to reply
2 replies to this topic

#1 Praesentius

Praesentius

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 12 April 2011 - 07:33 AM

Hey all,

One of my MP9 magazines has a fill problem, but it's not strictly the O-ring issue that so many folks deal with.  It looks like the stem that sticks straight up the middle of the fill valve is depressed to the point where it is flush with the bottom of the... well.  

I can still feed gas into the mag by taking steps to ensure that a seal is formed where the O-ring should be.  So, the valve is basically functional, but it's just not right like that.  

Does anyone have any ideas on whether or not the stem can be popped back out into its proper position?  Or should I just see about getting a replacement?

Thanks!

#2 dobey

dobey

    Enthusiast

  • Members
  • PipPip
  • 234 posts
  • Gender:Male
  • Location:NY
  • Country:

Posted 12 April 2011 - 03:38 PM

It sounds like the stem is broken off.  Did you use a metal adapter to fill it?  I always us an AI plastic adapter, never any of the metal ones.

#3 Praesentius

Praesentius

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 13 April 2011 - 04:12 AM

Yeah, it's a metal one.  I've been using a metal adapter for years on all kinds of mags without problems.  I coated the nozzle with RTV silicone so that I get good seals regardless the condition of any O-rings.  But if a plastic nozzle is less prone to do things like that, I'm open to switching.  

Thanks Dobey!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users