Jump to content


Mp9 Discharges All Gas


  • Please log in to reply
6 replies to this topic

#1 dabert234

dabert234

    Newbie

  • Members
  • Pip
  • 2 posts
  • Country:

Posted 02 March 2011 - 03:10 PM

Hey, so I got the KMP9 around christmas and I've played a few games with it no problem. I haven't played airsoft in awhile so I decided to do some target shooting, I loaded up the gun, went outside and pulled the trigger. All the gas discharged in one shot, I refilled thinking it was a one time thing. After 3 tries I've decided something is wrong, can someone tell me what is wrong and how do I fix it?

#2 BlackCloud

BlackCloud

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Los Angeles, California
  • Interests:Airsoft, and Engineering
  • Country:

Posted 03 March 2011 - 01:34 AM

Try a bit of cleaning, often times a small amount of dust or even lint can build up in the firing mechanisms also check that the loading nozzle fully returns when firing. On the Glock series, or M now, often times when people ran into this problem the cylinder return springs would wear out and need replacing. Sometimes after lots of use and no cleaning all the mechanisms that need to slid smoothly past each other stop sliding smoothly and need lubrication, it seems dumb but you would be surprised how often that will fix a gun.  

I am not saying that is the problem as I have not seen the gun, nor is this enough info to diagnose a problem off of.

#3 dobey

dobey

    Enthusiast

  • Members
  • PipPip
  • 234 posts
  • Gender:Male
  • Location:NY
  • Country:

Posted 03 March 2011 - 05:14 AM

I agree, time to clean the gun.  What happens is when you pull the trigger the valve striker pushes the valve in on the mag and it locks.  It will not stop pushing the valve open until to bolt moves back and trips a lever that will release the valve striker.  If the bolt cannot move correctly backwards the valve striker cannot be released and it will sit there and dump the gas till she is empty.  Focus your attentions on getting the bolt assembly cleaned up, if you are comfortable taking it apart I suggest washing it in the kitchen sink with warm water and dish soap and a tooth brush (not the one you use on your teeth :P).

If cleaning it doesn't fix it then make sure all the parts are in working order so the bolt can move freely.  The only other potential problem area could be the valve itself sticking.  Easy to check by gassing it up and pushing it in manually then releasing it.  If it closes quickly then it is the bolt.

#4 bigoleteddy

bigoleteddy

    Newbie

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Country:

Posted 18 April 2011 - 09:51 AM

This is probably not the case, but the valve cylinder could be cracked or chipped, bad seal, or as others suggested needs oil. Mine did that as well when the cylinder was broke, so take a look at that. Everytime i loaded it up, it all be gone as soon as i pull trigger.

#5 dabert234

dabert234

    Newbie

  • Members
  • Pip
  • 2 posts
  • Country:

Posted 16 August 2011 - 04:02 PM

UPDATE

So after months of delaying, I finally opened up my MP9 and saw this
Posted Image

A piece of plastic was there but snapped off a minute or so ago, it was nearly broken off when I was opening it. I'm not exactly airsoft tech smart, is that the cylinder thats broken? If not what part is that, and can I purchase it off the parts store?

#6 niko_gpsy

niko_gpsy

    What's a Warranty?

  • Super Moderator
  • PipPipPipPip
  • 5,880 posts
  • Gender:Male
  • Location:Atlanta, GA
  • Interests:Keeping those damn squirrels from putting their filthy little paws on my peaches in my backyard. Oh, Yes. It's not just a hobby, its a passion!!
  • Country:

Posted 16 August 2011 - 04:25 PM

Yes that does look like the cylinder that's cracked off. What gas are you using? Usually see damage like that in guns that run on propane and not green gas as recommended.
And that part should be available in the proshop but you should check to see if it's in stock.

#7 cjfoley96

cjfoley96

    Newbie

  • Members
  • Pip
  • 4 posts
  • Country:

Posted 27 November 2011 - 10:46 AM

i have the same problem. except i can shoot about 3 shots then it fires all the gas. the bot does not get pushed back all the way. no bbs fire




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users