Jump to content


M17 Hammer Assembly


  • Please log in to reply
1 reply to this topic

#1 Villain

Villain

    Newbie

  • Members
  • Pip
  • 19 posts
  • Location:Moorpark, CA - U.S.A.
  • Interests:Gotta love Airsoft! Been doing it since I was 14. Been using my Mac 11 for most of those years.

Posted 11 December 2008 - 02:13 PM

I have posted on other threads asking for some help. So far no one has helped me out. I hope someone can help.

I installed a new hammer spring in my M17 and I have been having firing issues.  I have some photos here of my assembly housing and wanted to see if anyone can comfirm that I put it together wrong or if it looks ok.

One other issue I wasn't so sure about (which can't be seen in any of the photos)Part No. 81
Part No. 81 sits under Part No. 78.
It looks awkward in that part 81 looks crooked when the hammer is pulled back in place.
There is a small hole on Part No. 78 that holds a spring but I'm not sure if PArt No. 81 is supposed to go into that hole?

Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image

#2 Spiggy

Spiggy

    Member

  • Members
  • PipPipPipPip
  • 2,136 posts
  • Gender:Male
  • Location:City of Industry
  • Country:

Posted 16 December 2008 - 12:46 PM

there's a bar on the 81 (disconnector) that passes through the 78 (striker)

try some diagnostics. Pull the trigger to deploy the 94 (hammer) forward and resetting the 94 (hammer) should set the striker into resting position.  Then depress the disconnector and see if the striker resets back into battery




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users