Jump to content


Mag not taking gas


  • Please log in to reply
6 replies to this topic

#1 lil_redd_again

lil_redd_again

    Newbie

  • Members
  • Pip
  • 14 posts
  • Country:

Posted 28 December 2010 - 12:50 PM

Hey hey new guy here, intros later, no time. Mags not taking gas. I have only used propane in all of about 6 full mags Ive fired since owning the gun. Mixed with silicone of course, more details if needed. But now about 7 mag in I guess the mag wont take a full charge of gas! It will take in about half a mags worth and then all the gas sprays every witch way out and around the adapater. Ill add some more details later but what does this sound like?

#2 airsofteen

airsofteen

    Enthusiast

  • Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Location:kansas
  • Country:

Posted 28 December 2010 - 02:47 PM

whats the temp where you are at?

#3 xKingSizex

xKingSizex

    Customer Service Manager

  • Administrators
  • PipPipPipPip
  • 1,809 posts
  • Gender:Male
  • Location:Long Beach, CA
  • Interests:Umm, airsoft...
  • Country:

Posted 28 December 2010 - 06:29 PM

Sounds like your adapter popped the o-ring out of the charging valve...

#4 lil_redd_again

lil_redd_again

    Newbie

  • Members
  • Pip
  • 14 posts
  • Country:

Posted 28 December 2010 - 07:12 PM

lunch break* I might say that it was pretty cold at maybe 40 degrees give or take a few BUT it was working fine the other day in the same temps. I didnt know there was an O ring in the charging valve, Ill look at that when I get home. I thought it could have been a faulty adapter but idk...

#5 xKingSizex

xKingSizex

    Customer Service Manager

  • Administrators
  • PipPipPipPip
  • 1,809 posts
  • Gender:Male
  • Location:Long Beach, CA
  • Interests:Umm, airsoft...
  • Country:

Posted 28 December 2010 - 08:21 PM

Most of the adapters cut into or pop out the o-rings. It will still take gas but won't fill without gas spewing out while doing it and will just take longer to fill.

#6 lil_redd_again

lil_redd_again

    Newbie

  • Members
  • Pip
  • 14 posts
  • Country:

Posted 29 December 2010 - 02:43 AM

So I got home and dropped the charging valve and I saw a rubber o ring on the outside, to seal the threads, and theres a little rubber ring on the inside where the adapter meets up. So idk if there was another o ring I popped out but the charging valve appears to be fine...Idk what the deal is..

#7 lil_redd_again

lil_redd_again

    Newbie

  • Members
  • Pip
  • 14 posts
  • Country:

Posted 31 December 2010 - 04:52 PM

Well I took the mag into the one and only local shop here in Tulsa and the owner who is apparently a gas gun guru or some sht put a tiny drop of what I could only call a plumbers thread sealer stuff inside the charging valve, not IN the hole but down around the stem of the valve and Ill be dammed if it will take a charge quite flawlessly now thats its cured a bit. I also got a fancy new metal propane adapter because thats all I can afford to use with this bad boy.

When funding permits Id like to get another mag or two but for now they are just too expensive. I may end up scooping a few new charging valves tho haha




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users