Jump to content


M18C Cycle Problem (Video Included)


  • Please log in to reply
5 replies to this topic

#1 PowerPickle

PowerPickle

    Newbie

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Location:Redondo Beach, CA
  • Country:

Posted 12 December 2010 - 06:54 PM

I seem to be having a problem with my M18C...but before I explain that I'll let you know that I installed a new Guarder hammer spring, G&P recoil spring(& spring guide), a Firefly plunger/floating valve, & a PGC CNC slide. Ok now. My problem i that whenever I try to fire the gun on full-auto it stops about an inch after starting to cycle back...before another BB can even be loaded. Once it's stuck like this I can't move it back forward. I can only pull it back. The only way I can get it to go back forward is to put it on semi-auto & let the slide go forward. Once I do that it starts to spew gas, so then I take the mag out. After all that's done, the slide works just fine. The thing is, this only happens on full-auto, never on semi. Any help would be appreciated. Thank in advance.HERE IS THE YOUTUBE LINK:

#2 Mikester619

Mikester619

    Enthusiast

  • Members
  • PipPip
  • 44 posts
  • Gender:Male
  • Location:San Diego CA
  • Country:

Posted 12 December 2010 - 07:18 PM

You need to sand the inside of the slide where the outer barrel and slide meets. I just installed a PGC silver slide with an extended tactical barrel yesterday. Same problem. I shoot in semi auto, shoots fine. When i shoot in full auto, the slide locks up and spews gas. The outer barrel is hitting the interior of the slide. Just use a Dremel and grind a little at a time, while checking the fittings. Make sure you examine where the slide locks up before grinding. Hope that helps.

Edited by Mikester619, 16 December 2010 - 10:11 PM.


#3 Italian13

Italian13

    Enthusiast

  • Members
  • PipPip
  • 175 posts
  • Gender:Male
  • Location:Ohio
  • Country:

Posted 12 December 2010 - 08:43 PM

Did you make sure that the cylinder return springs were installed then you put the BBU in the slide? Reason I ask is because of the cylinder sticking soo far forward.

#4 PowerPickle

PowerPickle

    Newbie

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Location:Redondo Beach, CA
  • Country:

Posted 12 December 2010 - 08:53 PM

View PostMikester619, on 12 December 2010 - 07:18 PM, said:

You need to sand the inside of the slide where the outer barrel and slide meets. I just installed a PGC silver slide with an extended tactical barrel yesterday. Same problem. I shoot in semi auto, shoots fine. When i shoot in full auto, the slide locks up and spews gas. The outer barrel is the hitting the interior of the slide. Just use a Dremel and grind a little at a time, while checking the fittings. Make sure you examine where the slide locks up before grinding. Hope that helps.

Thanks. I'll try that tomorrow.

View PostItalian13, on 12 December 2010 - 08:43 PM, said:

Did you make sure that the cylinder return springs were installed then you put the BBU in the slide? Reason I ask is because of the cylinder sticking soo far forward.

110% sure.

#5 PowerPickle

PowerPickle

    Newbie

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Location:Redondo Beach, CA
  • Country:

Posted 12 December 2010 - 08:53 PM

I figured out that its not the slide. It's the hammer. Somehow, its just not going all the way back down when I fire the gun in full-auto. Could it possibly be the new hammer spring?Any more help would be appreciated. Thanks.

Edited by PowerPickle, 13 December 2010 - 09:23 AM.


#6 PowerPickle

PowerPickle

    Newbie

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Location:Redondo Beach, CA
  • Country:

Posted 13 December 2010 - 12:39 PM

Ok never mind...PROBLEM SOLVED. It turns out that the little tail of the hammer spring wasn't on the ledge thats it's suppose to be on.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users