Jump to content


My KMP9 is not working correctly


  • Please log in to reply
45 replies to this topic

#41 MikeObrien

MikeObrien

    Newbie

  • Members
  • Pip
  • 15 posts
  • Gender:Male

Posted 04 April 2011 - 09:13 PM

View Postroguesqd, on 04 April 2011 - 03:21 AM, said:

So, I assume all those parts will be fixed in newer versions of the KMP9 releases?

Are they going to send current owners the new parts if we request them?

Great question! I would also like to know how kwa is dealing with these issues?

#42 roguesqd

roguesqd

    Enthusiast

  • Members
  • PipPip
  • 46 posts
  • Country:

Posted 05 April 2011 - 03:32 AM

Would be nice if they treated it like a 'recall' for a car, since it looks like a manufacturing design issue that would affect all released KMP9s.

#43 Grimreefer

Grimreefer

    Newbie

  • Members
  • Pip
  • 14 posts
  • Country:

Posted 05 April 2011 - 10:51 PM

View Postroguesqd, on 05 April 2011 - 03:32 AM, said:

Would be nice if they treated it like a 'recall' for a car, since it looks like a manufacturing design issue that would affect all released KMP9s.

Product recalls are usually for safety and liability reasons.  I'm happy as long as they improve on the design and keep up their reputation.

#44 Cashman1501

Cashman1501

    Enthusiast

  • Members
  • PipPip
  • 33 posts
  • Country:

Posted 29 October 2011 - 08:45 PM

PROBLEM SOLVED!!!! I figured out if you take the whole spring out and put the gun back together than it will work flawlessly. Dont really understand why its even there but so far it works great.

#45 jdl

jdl

    Enthusiast

  • Members
  • PipPip
  • 35 posts
  • Gender:Male
  • Location:Pennsylvania
  • Country:

Posted 06 May 2013 - 05:00 AM

Sorry to bump an old thread but I am having this exact issue. Was the resolution to remove the spring?   What spring, anyone have any pics?

#46 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,712 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 06 May 2013 - 06:34 PM

View Postjdl, on 06 May 2013 - 05:00 AM, said:

Sorry to bump an old thread but I am having this exact issue. Was the resolution to remove the spring?   What spring, anyone have any pics?
Actually, there was more than one issue referred to in this thread.  Can you describe your issue in detail.  Since this is a very old thread I would appreciate it if you start a new topic for your issue and we should be able to help you out.  Thank you!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users