Jump to content


M93R II Disassembly Help


  • Please log in to reply
4 replies to this topic

#1 huntingbronco

huntingbronco

    Newbie

  • Members
  • Pip
  • 3 posts
  • Country:

Posted 28 October 2010 - 03:39 AM

Hey guys - need a little help.  Been reading the forum to see about fixing a jamming problem.  My slide is not closing and I've read the solutions regarding seal #507.  My problem is I can't seem to get to it.  I've taken the screw 516 out and would expect the entire chamber assembly 514 along with 501 to drop straight down.  It is acting like there is something else holding the assembly in place.  Any help would be greatly appreciated.  

BTW is 502 in the diagram the black plastic piece in my gun? Is that called a chamber? My black plastic piece was very much stuck and took a fair amount of gentle persuasion to move it.  I'd really like to take it off, clean and inspect the seal to get it moving freely, which I presume is a prerequisite to proper functioning.

Thanks

#2 huntingbronco

huntingbronco

    Newbie

  • Members
  • Pip
  • 3 posts
  • Country:

Posted 29 October 2010 - 08:17 AM

View Posthuntingbronco, on 28 October 2010 - 03:39 AM, said:

Hey guys - need a little help.  Been reading the forum to see about fixing a jamming problem.  My slide is not closing and I've read the solutions regarding seal #507.  My problem is I can't seem to get to it.  I've taken the screw 516 out and would expect the entire chamber assembly 514 along with 501 to drop straight down.  It is acting like there is something else holding the assembly in place.  Any help would be greatly appreciated.  

BTW is 502 in the diagram the black plastic piece in my gun? Is that called a chamber? My black plastic piece was very much stuck and took a fair amount of gentle persuasion to move it.  I'd really like to take it off, clean and inspect the seal to get it moving freely, which I presume is a prerequisite to proper functioning.

Thanks

My question here is essentially the same as that just posted by x50xcaliberz, only he is asking about the M9 PTP.  I actually don't know how he got the cylinder and piston out without disassembly in the first place.  I can't even remove the fake firing pin peice that covers the screw that holds the piston. Just seems like we are missing a fastener or something that is holding that assembly in the slide.

Any help would be great.

#3 Soulkreig

Soulkreig

    Enthusiast

  • Members
  • PipPip
  • 45 posts
  • Gender:Male
  • Interests:Airsoft, Parkour.
  • Country:

Posted 30 October 2010 - 02:12 PM

Assuming I understand your problem, this has happened to me before. Check the gas nozzel thing on the slide and see if yours is coming back as far as mine:
Posted Image

If not, pull the gas nozzle thing foreward

Posted Image

In the back of the gas nozzle thing, there should be a metal ring. There will be a small gap in the ring.

Posted Image
Posted Image

When my gas nozzle wasn't coming all the way back, I noticed the gap in the ring was rotated slightly off center. So, I used my fingernail to rotate the gap back into the center and the slide started working again. If you have this problem and try this fix, take it slow and be careful not to dislocate the ring.

Hopefully this helps. :)

Edited by Soulkreig, 30 October 2010 - 02:16 PM.


#4 huntingbronco

huntingbronco

    Newbie

  • Members
  • Pip
  • 3 posts
  • Country:

Posted 31 October 2010 - 05:51 PM

Those are great pictures - thanks.  I figured out how to remove the assembly - the seal (507) was folded over. It now has a permanent kink in it, so I'll be ordering a new one of those. Thanks for the tip on keeping that notch aligned.

#5 Soulkreig

Soulkreig

    Enthusiast

  • Members
  • PipPip
  • 45 posts
  • Gender:Male
  • Interests:Airsoft, Parkour.
  • Country:

Posted 06 November 2010 - 05:01 AM

View Posthuntingbronco, on 31 October 2010 - 05:51 PM, said:

Those are great pictures - thanks.  I figured out how to remove the assembly - the seal (507) was folded over. It now has a permanent kink in it, so I'll be ordering a new one of those. Thanks for the tip on keeping that notch aligned.
Your welcome! I like to put pictures in with tutorials, I know how much they help. :lol: On a morning before a match, my gun developed this problem. While inspecting the gun to see what was wrong, I noticed the notch was off center and I thought "Seems like shomething that could cause a problem". So, I turned it and it started working, lol.

Glad you figured out what your problem was! :D




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users