Jump to content


KWA M17 Half Cycle


  • Please log in to reply
1 reply to this topic

#1 LoneWolf808

LoneWolf808

    Newbie

  • Members
  • Pip
  • 23 posts
  • Gender:Male
  • Location:Honolulu, Hawaii
  • Interests:Airsoft, Milsim, Autos, Explosions, Guns, Women, the usual Stuff
  • Country:

Posted 01 October 2010 - 01:03 PM

Hey there guys,

Just recentlly traded my KWA KP.45 For a KWA M17, and i seem to have a problem.

Some times, when I'm firing the gun, the slide half cycles and the magazine starts spewing gas like a volcano.

here are some of the Specs:

I believe the Slide Assembly is KWA, and the Body is KSC( i Think this may be the problem, but im not to sure)


Some of the My Guesses:

Temp of the Mag?

Loose Valves on the Magazine?

Loose Screw on the bottom rear of the slide (Can be seen on while the slide is locked back)


I would really like to get this up and running, I've been looking for this model since it's discontinue because i love the look of the M Series of KWA Pistols!

Thanks! and Aloha!

#2 Mikester619

Mikester619

    Enthusiast

  • Members
  • PipPip
  • 44 posts
  • Gender:Male
  • Location:San Diego CA
  • Country:

Posted 02 October 2010 - 05:38 AM

Aloha LoneWolf, welcome to the KWA forums. I had the same issues with my M19. I would fire one to two shots then it would spew all the gas from the magazine. I replaced the semi-sear(part#87), hammer(part#94), disconnector(part#81)and if needed impact hammer pin(part#78). Also check the spacing between the gas chamber block(part#88)and the lower frame(part#105,#93). I also had to put spacers between the gas chamber block(part#88) and the slide(part#119). Hope this helps. Take care Mahalo.

To the KWAUSA.com customer service, I like to say thank you to Melissa and the rest of the staff at KWAUSA.com for the speedy delivery of the parts i ordered.

Edited by Mikester619, 02 October 2010 - 05:44 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users