Jump to content


1911 problem, the slide won't go forward fully, help !


  • Please log in to reply
3 replies to this topic

#1 Sgt Jack Carter

Sgt Jack Carter

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 25 August 2010 - 09:14 PM

Hi everybody, I'm new to the forum. first of all, I've bought a KWA 1911A1 2 days ago and I dropped my mag, but the mag is ok, I think, no major scratches and most important, the mag don't leak. ( It did not fall on the mag head, where the bb's poping out) But it's not the problem here, I fired my gun, everythings was fine until I refill my mag, put bb's, put the mag in the gun, and cock the gun..... When I let the slide go forward, to arm the bb in the barrel, most of the time it jam, the slide won't go fully forward, and of cours it won't fire. But without the mag, everytings perfect. ( And sometime it's shoot fine with the mag full of bb's, until it jammed) So I really think it's the piece No.7 who jam the bb between the head of the mag, where the bb start, and the piece 18. When it jam, I cock the gun back and see that the bb is still between the two pieces an not in the cylinder. So I think something just not fully slide the bb in the proper place when it cock forward.

1. I've already tighten the 2 little screws near the spring guide and the special screw no.29 just under the back of the slide.
2. Is it normal that the outer barrel ( part No.3 ) and Part No. 7 are moving alot ? I mean not they can fall of but they are not fixed ?


Can anyone help me ?? Please I'm just clueless, I don't know what to do :(

Attached Files


Edited by Sgt Jack Carter, 25 August 2010 - 09:17 PM.


#2 Sgt Jack Carter

Sgt Jack Carter

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 26 August 2010 - 02:14 PM

Ok I've noticed the probleme my self, it was the bb's. I don't know why, but my Armist .20 do not work in my Colt, but the Crossman .25 work perfectly... I'm gonna buy better bb's just for my Colt, I'm not gonna stick with those weak bb's for very long I swear :P Thank you.

#3 Guest_allizard_*

Guest_allizard_*
  • Guests

Posted 27 August 2010 - 08:54 AM

I recommend using KSC bbs.

#4 stevemcgee99

stevemcgee99

    Enthusiast

  • Members
  • PipPip
  • 39 posts

Posted 19 May 2011 - 11:18 AM

Clean the BB ramp.  I get this problem, partly because the hop-up tool is not designed well so it scratches the BB ramp when used.  But just clean it and polish it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users