Jump to content


MP7 Not charging when handle is pulled back and released


  • Please log in to reply
10 replies to this topic

#1 RolfHarris

RolfHarris

    Enthusiast

  • Members
  • PipPip
  • 48 posts

Posted 02 August 2010 - 12:46 PM

Hi
OK got a major problem with the MP7 GBB
Mags are fully charged and loaded.
Charging handle pulled back and released
Pull trigger nothing, Pull charging handle again some times a BB falls out of the side some times It's jammed in the barrel have to use the cleaning rod to unjam.
Yes it's not in safety mode !
All burs are removed from all 5 KWA Long Mags as I did have to clean the edges so the BB's could be loaded OK.

Only ever used Super Power Green Gas (Im in the UK)
Has the Bucking swollen, seems there is a large problem with this? If so what is KWA doing about this?
How can I check the Bucking with out stripping down my gun?

MP7 has only done I would say 2000 bb's max

Cheers
Rolfy

#2 cjboi

cjboi

    Enthusiast

  • Members
  • PipPip
  • 150 posts
  • Gender:Male
  • Location:CANADA

Posted 02 August 2010 - 01:05 PM

View PostRolfHarris, on 02 August 2010 - 12:46 PM, said:

Hi
OK got a major problem with the MP7 GBB
Mags are fully charged and loaded.
Charging handle pulled back and released
Pull trigger nothing, Pull charging handle again some times a BB falls out of the side some times It's jammed in the barrel have to use the cleaning rod to unjam.
Yes it's not in safety mode !
All burs are removed from all 5 KWA Long Mags as I did have to clean the edges so the BB's could be loaded OK.

Only ever used Super Power Green Gas (Im in the UK)
Has the Bucking swollen, seems there is a large problem with this? If so what is KWA doing about this?
How can I check the Bucking with out stripping down my gun?

MP7 has only done I would say 2000 bb's max

Cheers
Rolfy


Do not I repeat Do not use silicone oil with aerosol premix in it. Yes most likely your hop up bucking swelled up. You can order the parts from the pro shop. You just need to find 1mm allen key / HEX key to open the whole gas system.

#3 RolfHarris

RolfHarris

    Enthusiast

  • Members
  • PipPip
  • 48 posts

Posted 02 August 2010 - 10:13 PM

View Postcjboi, on 02 August 2010 - 01:05 PM, said:

Do not I repeat Do not use silicone oil with aerosol premix in it. Yes most likely your hop up bucking swelled up. You can order the parts from the pro shop. You just need to find 1mm allen key / HEX key to open the whole gas system.

Hi
I have never used Silicone Oil aerosol..

Update:
I have put one drop of pure silicone that comes with the MP7 from KWA on the top of the Mag air vale and gas out take..
All 5 mags now charge and fire.. Later will put all mags with .25 BB's through it and see what happens..
I'll post results..

Rolfy

#4 cjboi

cjboi

    Enthusiast

  • Members
  • PipPip
  • 150 posts
  • Gender:Male
  • Location:CANADA

Posted 03 August 2010 - 12:01 AM

View PostRolfHarris, on 02 August 2010 - 10:13 PM, said:

Hi
I have never used Silicone Oil aerosol..

Update:
I have put one drop of pure silicone that comes with the MP7 from KWA on the top of the Mag air vale and gas out take..
All 5 mags now charge and fire.. Later will put all mags with .25 BB's through it and see what happens..
I'll post results..

Rolfy

some green gas contain silicone oil that has aerosol premix in it.... you did mention your using some kind of super power green gas, never heard of such thing "only green gas or red gas or delta gas". But ya check your green gas and see whats in it.

#5 cjboi

cjboi

    Enthusiast

  • Members
  • PipPip
  • 150 posts
  • Gender:Male
  • Location:CANADA

Posted 14 September 2010 - 04:57 PM

ok I finally got my new bolt carrier, but for some reason I still have to cock the gun twice before it starts firing. What the heck is wrong with my gun? Should I get a new nozzle too? or shave off part of the nozzle for it to move smoothly? Tiger told he had the same situation, but that's what I did. I basically got myself a new bolt but, its doing the same thing. HELPPPPPP

#6 cjboi

cjboi

    Enthusiast

  • Members
  • PipPip
  • 150 posts
  • Gender:Male
  • Location:CANADA

Posted 14 September 2010 - 05:54 PM

I thought it was the striker tip that was short, but why do I have to cock it twice for it to work? I need help from all the KWA experts. I already ordered the 1mm and .9mm allen key / hex key, so i can examine whats wring with the gun myself. I feel like part #88 is not moving right to set the trigger for it to hit the hammer.

#7 RolfHarris

RolfHarris

    Enthusiast

  • Members
  • PipPip
  • 48 posts

Posted 14 September 2010 - 10:14 PM

View Postcjboi, on 14 September 2010 - 05:54 PM, said:

I thought it was the striker tip that was short, but why do I have to cock it twice for it to work? I need help from all the KWA experts. I already ordered the 1mm and .9mm allen key / hex key, so i can examine whats wring with the gun myself. I feel like part #88 is not moving right to set the trigger for it to hit the hammer.

Mine now Does Not work at all! When pulling back on the charge handle the piston gets stuck, have cleaned and lubricated all of the slide area but still no joy.. BB's get jammed all the time and YES I'm using Premium BB's MadBull, Blasters, ect ect
This Gun has been a piece of sh*t since day 1!! I have always had problems with this gun and the mags since it was brand new..

#8 xKingSizex

xKingSizex

    Customer Service Manager

  • Administrators
  • PipPipPipPip
  • 1,809 posts
  • Gender:Male
  • Location:Long Beach, CA
  • Interests:Umm, airsoft...
  • Country:

Posted 14 September 2010 - 10:46 PM

Get on the Help Desk www.kwausa.com/support and send your gun in so we can check it out to see what's going on.

#9 cjboi

cjboi

    Enthusiast

  • Members
  • PipPip
  • 150 posts
  • Gender:Male
  • Location:CANADA

Posted 14 September 2010 - 10:51 PM

View PostxKingSizex, on 14 September 2010 - 10:46 PM, said:

Get on the Help Desk www.kwausa.com/support and send your gun in so we can check it out to see what's going on.

I live in Canada. I could only send the whole bolt system but not the gun itself.

#10 RolfHarris

RolfHarris

    Enthusiast

  • Members
  • PipPip
  • 48 posts

Posted 15 September 2010 - 11:42 AM

View PostxKingSizex, on 14 September 2010 - 10:46 PM, said:

Get on the Help Desk www.kwausa.com/support and send your gun in so we can check it out to see what's going on.

Problem with that I'm in the UK!

#11 cjboi

cjboi

    Enthusiast

  • Members
  • PipPip
  • 150 posts
  • Gender:Male
  • Location:CANADA

Posted 15 September 2010 - 02:07 PM

do you guys need the whole gun or can I just send the whole bolt system itself? Once my gun leaves my country, it cant go back




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users