Jump to content


Need Help Please


  • Please log in to reply
2 replies to this topic

#1 Hitman07

Hitman07

    Guru

  • Members
  • PipPipPipPip
  • 1,018 posts
  • Gender:Male
  • Location:USA
  • Interests:YouTube, Airsoft/Paintball, and Computers
  • Country:

Posted 08 February 2010 - 07:39 PM

Hey guys does anyone own a KWA M226?

I have the new version and sometimes the slide doesnt rack all the way forward or back

I looked closely and saw there was a lot of friction with the slide the the trigger and a lot of paint off on the rails (gray) anyway for instance sometimes it doesnt cock back all the way when its out of BBs and if it does say i put a new mag in and then push the bolt release down the slide wont go all the way forward...

What can I do to fix this?

Do I need to put lube on it somewhere?

Thanks

#2 tiki2777

tiki2777

    Newbie

  • Members
  • Pip
  • 19 posts

Posted 12 February 2010 - 05:13 PM

Yea I got mine like that too, all you need to do is use a spray lubricant like the UTG kind.

#3 PLANofMAN

PLANofMAN

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 17 February 2010 - 04:16 AM

take a couple q-tips and rub them in the spots where you have metal to metal contact, when they come out clean, put a drop of silicone oil on a q-tip and lightly wipe the spots where there is metal to metal contact. If this doesn't solve your problem a light buffing with steel wool or a dremel with a polishing bit and a repeat of the above instructions will solve your problems. A clean gun is a wonder to shoot. (less friction=less gas consuption) remember lots of silicone oil means a higher chance of dust and grime sticking to your gun so use a small amount of oil, but oil often.

you should lube up all seals and anything that moves. hammer pivot, piston, and trigger pivot each get one drop. one drop will also cover the slide rails (top and bottom) and don't forget the seals on your mag as well. doing this every other time you event with your gun will keep wear to a minimum.  The oil that comes with the gun will work fine. don't lube your hop-up or inner barrel. the hop-up should be getting enough lube from the green gas.

Edited by PLANofMAN, 17 February 2010 - 04:23 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users