Jump to content


Different Slide Issue


  • Please log in to reply
7 replies to this topic

#1 MP7dad

MP7dad

    Newbie

  • Members
  • Pip
  • 29 posts

Posted 08 November 2009 - 11:23 PM

This weekend, my son's KP45's slide started to misbehave by not locking in the open position when shooting the last BB. I didn't see any damage to the BB follower and magazine like in the MP7 thread. When I get back from my business trip I'll check the "infamous" spring but I believe all the issues I've seen related to that spring is the lock engaging when it shouldn't where he is having the opposite happen.

The first thing I'll do is make sure the spring is still there.

Any other things to check besides cleaning the gun?

Up until now, the KP has performed flawlessly. I was going to buy myself the same one but then I saw the M9 PTP was pretty nice looking and has a higher FPS rating so that is diverting my attention from the fact that I'm a USP fan to begin with (went and checked out the real ones at our local shop and range. They have one in their rentals but were out of rounds for it. They have 20 twenty-five yard indoor lanes.

My hk hat is on the way if that tells you anything  :jump:

#2 Spiggy

Spiggy

    Member

  • Members
  • PipPipPipPip
  • 2,136 posts
  • Gender:Male
  • Location:City of Industry
  • Country:

Posted 09 November 2009 - 05:30 PM

manually cycling the slide, does the catch engage?

#3 MP7dad

MP7dad

    Newbie

  • Members
  • Pip
  • 29 posts

Posted 09 November 2009 - 07:56 PM

View PostSpiggy, on 09 November 2009 - 05:30 PM, said:

manually cycling the slide, does the catch engage?

Just talked to my son, he says it engages when manually cycling on an empty magazine, it just doesn't when shooting the last BB....

#4 Spiggy

Spiggy

    Member

  • Members
  • PipPipPipPip
  • 2,136 posts
  • Gender:Male
  • Location:City of Industry
  • Country:

Posted 10 November 2009 - 10:01 AM

Ok, one of two things may be happening.

1. the hairpin spring indicated in the "slide lock misbehavior" thread might be too strong for the magazine follower spring.

2. The magazine follower itself may be dirty and will require some cleaning.  Any amount of dirt or bb residue may stop the function of the follower, which will not activate the slide lock.

#5 MP7dad

MP7dad

    Newbie

  • Members
  • Pip
  • 29 posts

Posted 10 November 2009 - 08:03 PM

View PostSpiggy, on 10 November 2009 - 10:01 AM, said:

Ok, one of two things may be happening.

1. the hairpin spring indicated in the "slide lock misbehavior" thread might be too strong for the magazine follower spring.

2. The magazine follower itself may be dirty and will require some cleaning.  Any amount of dirt or bb residue may stop the function of the follower, which will not activate the slide lock.

Thanks, I'll look into cleaning the magazine when I get back...

#6 Asuna

Asuna

    Newbie

  • Members
  • Pip
  • 21 posts
  • Gender:Not Telling
  • Location:NOYB

Posted 10 November 2009 - 09:59 PM

Interestingly I have this issue at times too. I narrowed mine down to the gas capacity in my magazine. It leaks...so It leaks out just enough to cycle but not push the slide back far enough to lock back

#7 ducs

ducs

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 21 November 2009 - 07:50 PM

I too am having this problem. When looking closely, it appears that the slide does not kick far enough back to lock, which would make me believe its a gas issue not a spring issue. I am fairly certain my mag does not leak though, so I'm wondering if when the mag is in, the little rubber bushing is not making a tight enough seal.


any ideas anyone? I was wondering if maybe a light coat of silicon on the rubber bushing might help keep the seal.

#8 Breetai

Breetai

    Newbie

  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Location:Bakersfield, CA
  • Interests:Hunting, Shooting, Offroading

Posted 14 March 2010 - 09:52 AM

Same with mine. I can shoot it without any bbs and it does not lock back. I will try cleaning and putting a small amount of oil on the bushing to see if that helps. I also thought that I just did not get enough gas into the mag. Still trying to figure out when I have got it filled right, this is my first gbb airsoft so it will take me time to get used to it but I am having fun and my kp45 is a great gun.
Breetai
I tried some oil but the slide does not lock back after the last bb is fired but if I shoot it with no bbs the slide locks back. could it be the spring or is it something else?

Edited by Breetai, 14 March 2010 - 10:22 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users