Jump to content


M9 Firing Problem.


  • Please log in to reply
2 replies to this topic

#1 Votter

Votter

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 26 August 2009 - 07:22 PM

So I've had my M9 Tactical PTP for about a year now. It's seen good use and some abuse (from dropping out of the holster). But nothing seemed to happen until last weekend. While firing during the game it double tapped (almost full auto) with one pull of the trigger. I then went to a shooting area and tried firing it thinking it was a one time trigger arm slip or something. It fired twice again. Then on the next pull (I held the trigger down to see if it was just a double of a full burst) and it fired a good seven shots before stopping.

Does anyone know anything I can do to fix this problem? Or what part needs to be replaced.

Also the screws on the left side of my grip are stripped so if anyone knows an easy way to remove stripped screws please tell me.



I fixed all the problems. I sanded down the latches on the hammer and cleaned the inside. The notches became almost rounded making it not catch anymore. Between the mud, sand and some grass bits in the internal I think that may be what caused it to miss fire. And I dremeled the screws to loosen them.

Edited by Votter, 26 August 2009 - 08:27 PM.


#2 Guest_Box Goblin_*

Guest_Box Goblin_*
  • Guests

Posted 27 August 2009 - 11:53 AM

I check the hairpin spring that levels the trigger transfer bar, it can be out of shape as well cause that problem

Edited by Box Goblin, 27 August 2009 - 11:54 AM.


#3 Votter

Votter

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 27 August 2009 - 12:24 PM

I've replaced that a while ago but it looks fine. There was a lot of dirt and sand and grass in the hammer area though. When I cleaned that and filed down the latches it worked fine. Thanks for the info I'll get watch on that spring.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users