Jump to content


Blowback but not firing pellets


  • Please log in to reply
3 replies to this topic

#1 aaron832

aaron832

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 15 June 2009 - 06:35 PM

I have a kwa m11a1.  One day while I was out shooting the gun suddenly stopped firing bbs.  The blow back function works perfectly but pellets do not come out of the barrel... or simply roll out.  I pretty much took it completely apart.  The piston looks to be ok.  Inside the holes of the piston I can see the small piece #43 and #45 and can stick an allen wrench through the barrel to move it back.  It springs forward as expected.  I am guessing that when the gas enters the area that little part #43 is not either pushed or pushing back on the spring?  I am not sure how the physics of it works.   It seems that spring is going to keep if that little plug forward and clogging the hole for the air to get through the barrel part.  It seems instead the air would go back into the spring area and the bottom of the piston.  Any insight into my issue would be greatly appreciated!  Thanks!

#2 Spiggy

Spiggy

    Member

  • Members
  • PipPipPipPip
  • 2,136 posts
  • Gender:Male
  • Location:City of Industry
  • Country:

Posted 16 June 2009 - 09:17 AM

have you oiled it or taken a dirty dust dive recently?

#3 aaron832

aaron832

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 16 June 2009 - 12:33 PM

I have taken it apart about a dozen times and cleaned / oiled it.  No dirt really ever got inside.  All the parts move about the same as they used to if not better.
Thanks for your reply.

#4 Guest_allizard_*

Guest_allizard_*
  • Guests

Posted 17 June 2009 - 03:20 PM

Well, you do have an options to send it in for service.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users