Jump to content


Feading problems with KM4 CQB


  • Please log in to reply
4 replies to this topic

#1 CaptCabose

CaptCabose

    Newbie

  • Members
  • Pip
  • 3 posts
  • Country:

Posted 06 October 2013 - 02:09 PM

So i got a new gun. My first kwa m4. it got it used off craigslist. anyhow. It stopped firing full auto and idk why. it fires every shot in semi but once i switch to full it fires about 1 every 5 "shots." anyone know how to fix this? do i need a new hop up or what? i looked at the hopup i have now and it looks all good, the bucking isnt broken so idk.

#2 niko_gpsy

niko_gpsy

    What's a Warranty?

  • Super Moderator
  • PipPipPipPip
  • 5,878 posts
  • Gender:Male
  • Location:Atlanta, GA
  • Interests:Keeping those damn squirrels from putting their filthy little paws on my peaches in my backyard. Oh, Yes. It's not just a hobby, its a passion!!
  • Country:

Posted 10 October 2013 - 04:18 AM

The issue can be a hop up problem or it can be something to do with the selector plate not engaging correctly.  It's very difficult to diagnose your problem with what little info you have provided.  Do you notice the bb's jammed in the hop up unit?

#3 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,562 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 11 October 2013 - 04:06 PM

View Postniko_gpsy, on 10 October 2013 - 04:18 AM, said:

The issue can be a hop up problem or it can be something to do with the selector plate not engaging correctly.  It's very difficult to diagnose your problem with what little info you have provided.  Do you notice the bb's jammed in the hop up unit?
That and one or more of the following:
  • Poor ammo
  • Damaged or incompatible mags
  • Spring missing from in front of the hop-up - Is the FPS inconsistent?
  • Damaged or incompatible tappet plate
  • Non-compatible aftermarket parts
  • Damaged feed ramp, or a feed ramp that is improperly installed
  • Front wires  pushing against the feed ramp
How much did you pay, what is the general condition of the gun, and age of the gun, and can you get your money back?

#4 CaptCabose

CaptCabose

    Newbie

  • Members
  • Pip
  • 3 posts
  • Country:

Posted 15 October 2013 - 05:18 PM

it was the lower hop up part. it was bent in and such not letting the bbs feed into the gun, Thanks guys.

#5 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,562 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 15 October 2013 - 05:50 PM

View PostCaptCabose, on 15 October 2013 - 05:18 PM, said:

it was the lower hop up part. it was bent in and such not letting the bbs feed into the gun, Thanks guys.
The feed ramp.  Yes, that will do it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users