Jump to content


Bolt carrier problem with PMags


  • Please log in to reply
4 replies to this topic

#1 catito14

catito14

    Newbie

  • Members
  • Pip
  • 10 posts
  • Country:

Posted 03 October 2013 - 08:45 PM

Hi guys, today i have received 2 PMags (one is fine and the other has leaks grrrrrr). After shooting a couple of rounds in semi and full i noticed that the bolt carrier get stuck in the back and dont make the whole way (just like if you pull the charging handle without bbs in the mag). I havent this issue with the standard mag, just with the PMag.
Anyone can help me please??
Thanks in advance and sorry for my poor english.

Regards

#2 catito14

catito14

    Newbie

  • Members
  • Pip
  • 10 posts
  • Country:

Posted 06 October 2013 - 07:40 AM

Nobody had this problem before? Or is it just my English that is not understood?

#3 Chuck S

Chuck S

    Guru

  • Members
  • PipPipPipPip
  • 1,316 posts
  • Gender:Male
  • Location:Cleveland, Ohio
  • Country:

Posted 06 October 2013 - 08:39 AM

Not had this problem personally.  If the bolt is locking back I assume the bolt catch is engaging.  That right?  If the detent is missing in the bolt catch assembly the recoil can cause the lock to jump up and engage the bolt.  Had this part out of the gun?  The spring modification deletes the detent and uses a spring to keep the bolt lock disengaged.

Any modifications to the gun?

-- Chuck

#4 General Pickle

General Pickle

    Specialist

  • Members
  • PipPipPip
  • 313 posts
  • Gender:Male
  • Location:Oregon
  • Interests:tactical stuffs(airsoft, real steel, knives etc.), mechanical and manufacturing engineering, computers, gaming, the great outdoors
  • Country:

Posted 06 October 2013 - 10:06 AM

I've had my LM4 lock to the rear a couple times with loaded PMags but not consistently, and that hasn't happened for over 3 months. I would suggest the bolt catch mod, that and maybe open up the PMags to see if there's any dirt or debris that could be causing the bolt catch levers to function improperly.

#5 akiraspeedstar

akiraspeedstar

    Guru

  • Members
  • PipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Country:

Posted 06 October 2013 - 02:58 PM

When I first bought PMAGs I immediately had issues with the bolt lock engaging and borrowed a tool from the arena worker to work on the bolt cagch arm so it was farther from the mag and it stopped. The worker told he had the exact same issie as soon as he bought a pmag and sold them immediately.

Even after that itd every now and then engage but it wasnt common. I numbered the top of my magazines and discovered it was one magazine causing the issue. I found that the magazine catch opening was larger than the others and was allowing the mag to jump up when firing. I added some jb weld to the mag body and filed it to replicare the others and it it stopped.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users