Jump to content


mk2 1911 ptp not firing properly need help!


  • Please log in to reply
4 replies to this topic

#1 angrybanana

angrybanana

    Newbie

  • Members
  • Pip
  • 2 posts
  • Country:

Posted 30 September 2013 - 03:40 PM

Hi guys/gals, in need of some help went to shoot my mk2 1911 ptp. Got the gun only 2 weeks ago haven't even gotten a chance to use it in a game yet, but went to shoot some targets with it the other day filled it up with gas and bbs cocked it back pulled the trigger and "click" nothing. Firing pin seems to still be in there. after about 20 times of cocking it back and pulling the trigger it would fire and then nothing. Sometimes i would be able to fire off a few shots but if i stopped it would continue with this problem. figured i look on here for some help before i have to go through the hassle of bringing it back all help is appreciated thanks.

#2 Chuck S

Chuck S

    Guru

  • Members
  • PipPipPipPip
  • 1,320 posts
  • Gender:Male
  • Location:Cleveland, Ohio
  • Country:

Posted 01 October 2013 - 02:47 AM

Two weeks old?  I'd have the box enroute to KWA this afternoon!

-- Chuck

#3 angrybanana

angrybanana

    Newbie

  • Members
  • Pip
  • 2 posts
  • Country:

Posted 01 October 2013 - 02:28 PM

you think i should send it in to kwa? or bring it back to my local store where i got it

#4 Chuck S

Chuck S

    Guru

  • Members
  • PipPipPipPip
  • 1,320 posts
  • Gender:Male
  • Location:Cleveland, Ohio
  • Country:

Posted 02 October 2013 - 03:00 AM

KWA will fix it right.  Your local store may not have the parts required.

-- Chuck

#5 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,665 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 02 October 2013 - 07:23 AM

View Postangrybanana, on 30 September 2013 - 03:40 PM, said:

Hi guys/gals, in need of some help went to shoot my mk2 1911 ptp. Got the gun only 2 weeks ago haven't even gotten a chance to use it in a game yet, but went to shoot some targets with it the other day filled it up with gas and bbs cocked it back pulled the trigger and "click" nothing. Firing pin seems to still be in there. after about 20 times of cocking it back and pulling the trigger it would fire and then nothing. Sometimes i would be able to fire off a few shots but if i stopped it would continue with this problem. figured i look on here for some help before i have to go through the hassle of bringing it back all help is appreciated thanks.
When it does fire is it at the extreme end of the trigger pull....this is important to know.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users