Jump to content


KWA MKII PTP - Firing Issues and Cycling

KWA 1911 hammer firing impact

  • Please log in to reply
6 replies to this topic

#1 General Pickle

General Pickle

    Specialist

  • Members
  • PipPipPip
  • 308 posts
  • Gender:Male
  • Location:Oregon
  • Interests:tactical stuffs(airsoft, real steel, knives etc.), mechanical and manufacturing engineering, computers, gaming, the great outdoors
  • Country:

Posted 11 August 2013 - 02:29 AM

Hey guys! So after about 3 years of having my MKII I seem to have an issue with the impact hammer, part 34 and 35 perhaps or maybe it's due to the leaf spring not working properly? I'm not exactly sure what the problem part is but what's happening is that when I fire the gun there is not enough gas being let into the gun to cycle the slide and load another BB. It started happening a few weeks ago, where the action just seemed a little sluggish and less crisp. It felt like the mag was running out of gas, however I have determined with multiple magazines that the mags have plenty of gas. I thought that perhaps I just needed to clean it more so I went ahead and did my normal cleaning by field stripping the gun and cleaning/lubing the friction points with a small drop of froglube, but this only got me one solid shot before the same issue returned, but now the slide no longer feels sluggish rather it doesn't cycle at all; when I fire the gun it makes a "PIP" sound and manages to launch the chambered BB at fairly normal velocity, though it doesn't seem to be full power, and the slide only moves back a tiny bit so that it half cocks the hammer and fails to cycle another round. My guess is that there is not enough force being transferred to the release valve, thus not releasing enough gas into the system. So I went ahead and fully disassembled the trigger assembly and lower frame, in which I found a fair amount of dirty build up in most of the parts, then I assembled everything and tried again only to get the same results as before (at least I didn't cause any other problems...) which brings me to a couple conclusions: The hammer spring may be losing its tension, the impact hammer may not be functioning correctly, or perhaps part 75 is not doing what it's supposed to. Any advice or help is much appreciated!

-Wrecker

#2 General Pickle

General Pickle

    Specialist

  • Members
  • PipPipPip
  • 308 posts
  • Gender:Male
  • Location:Oregon
  • Interests:tactical stuffs(airsoft, real steel, knives etc.), mechanical and manufacturing engineering, computers, gaming, the great outdoors
  • Country:

Posted 16 August 2013 - 12:20 AM

Update: After completely diving into the lower and upper assemblies I found that the issue was perhaps more simple than I thought. The upper nozzle assembly was gummed up with too much lube/dirt. I have been dropping Froglube into this nozzle to maintain the nozzle seal for almost 3 years now with no issues, but after that much time and use it only seems logical that dirt and dust would accumulate in the lube that had worked its way deep into the assembly. After reassembly I was able to fire quick and crisp shots, almost feels better than when it was new. Hopefully if somebody else runs into this issue they may see this and be able to identify their issue as well. So I've learned that if you're going to use a thick lube in your gun then make sure to check on the tight spaces now and then so they don't get super gummed up.

#3 General Pickle

General Pickle

    Specialist

  • Members
  • PipPipPip
  • 308 posts
  • Gender:Male
  • Location:Oregon
  • Interests:tactical stuffs(airsoft, real steel, knives etc.), mechanical and manufacturing engineering, computers, gaming, the great outdoors
  • Country:

Posted 29 October 2013 - 07:37 PM

Another update: Well it seems I spoke too soon. Cleaning out the gun was certainly helpful, however the problem is still here. I've spent a lot of time trying to figure out exactly what's wrong with the gun and at this point I'm getting a little frustrated. My latest deduction is that the grooves in part #27 are worn down and the edge of part #33 are not meshing properly, causing a lot of friction between the slide and the lower frame. For whatever reasons, my part #27 is worn out quite a lot in various places. Perhaps this is why the slide is unable to cycle correctly? Has anybody else had this issue or is this an isolated case?

#4 SR105

SR105

    Tech

  • KWA Staff
  • PipPip
  • 123 posts
  • Gender:Male
  • Location:Walnut, CA
  • Country:

Posted 29 October 2013 - 11:43 PM

Actually it sounds very much like a snappe impact block spring (part 75). If this spring snaps then the impact block (35) will not stay down where it is supposed to impact the magazine release valve.

#5 General Pickle

General Pickle

    Specialist

  • Members
  • PipPipPip
  • 308 posts
  • Gender:Male
  • Location:Oregon
  • Interests:tactical stuffs(airsoft, real steel, knives etc.), mechanical and manufacturing engineering, computers, gaming, the great outdoors
  • Country:

Posted 30 October 2013 - 08:25 AM

SR105, I appreciate your response. My initial guess involved that area, though I just inspected part #75 once more and verified that it is intact and functioning properly. Another clue just showed itself to me as I was putting the slide back together, that the slide was literally becoming seized up and stuck about halfway through the cycle. I am convinced that this is a friction issue between the slide assembly and the lower components. As a side note, I have tried to submit a KWA Help Desk ticket but the system is not allowing me to do so. It says that I have selected an invalid department and that not all fields are filled out, though both of those statements are clearly untrue.

Attached File  IMG_0876.JPG   84.9K   17 downloads

This is the area I am most concerned about.

Edit: After putting a very light coat of Froglube on the 'friction spots' the issues seem to clear up and the slide will even lock back.

Edited by General Pickle, 30 October 2013 - 10:51 AM.


#6 Kimber45cal

Kimber45cal

    Newbie

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Holiday Florida
  • Interests:Guns shooting hunting big and small game motorcycles street&dirt just getting into airsoft thanks to my son who has a Knighthawk 1911 45 gas blow back pistol and a L96 sniper rifle.
  • Country:

Posted 20 February 2014 - 10:54 PM

General Pickle, I am having what sounds like the problem with my MKlll. I think that part # 36 is worn down or part #27 is worn because I can get the gun to fire 1 or 2 rounds and the impact block sticks and all the gas is shot out and the slide will not return.part # 36 I have to push down by finger so the impact block will go back and then I can get it to fire again.I have been trying to get part # 36 from KWA for about 1 year now and I call every 2 weeks and I am told the same thing OUT OF STOCK_DON'T KNOW WHEN IT WLLL BE IN STOCK. I loved the gun before I had to TRY and get parts now I wish never bought it. Now Ibuy WE guns and have very little  trouble with them and if I do have trouble PARTS are easer to find. I think the answer to this problem is to spend the $110.00 o  new slide because the  parts are OUTOF STCK-but he slides are not...  Good luck getting parts.

    K45

#7 InvisibleReality

InvisibleReality

    Newbie

  • Members
  • Pip
  • 1 posts
  • Country:

Posted 26 February 2014 - 10:17 AM

View PostKimber45cal, on 20 February 2014 - 10:54 PM, said:

General Pickle, I am having what sounds like the problem with my MKlll. I think that part # 36 is worn down or part #27 is worn because I can get the gun to fire 1 or 2 rounds and the impact block sticks and all the gas is shot out and the slide will not return.part # 36 I have to push down by finger so the impact block will go back and then I can get it to fire again.I have been trying to get part # 36 from KWA for about 1 year now and I call every 2 weeks and I am told the same thing OUT OF STOCK_DON'T KNOW WHEN IT WLLL BE IN STOCK. I loved the gun before I had to TRY and get parts now I wish never bought it. Now Ibuy WE guns and have very little  trouble with them and if I do have trouble PARTS are easer to find. I think the answer to this problem is to spend the $110.00 o  new slide because the  parts are OUTOF STCK-but he slides are not...  Good luck getting parts.

K45

I have had trouble getting parts as well, until I got in contact with Gus. His email is guso@kwausa.com and on two separate occasions I emailed for parts through a ticket and they didn't have them, and then I sent an email to Gus and he got them to me.





Also tagged with one or more of these keywords: KWA, 1911, hammer, firing, impact

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users