Jump to content


Kmp9 firing issues

kmp9 issues

  • Please log in to reply
1 reply to this topic

#1 TewMch

TewMch

    Newbie

  • Members
  • Pip
  • 1 posts
  • Country:

Posted 30 July 2013 - 01:43 PM

Ok so I have two kmp9's with the same exact issue. Both will shoot around 10-15 shots on semi before the bolt does not fully cycle and then expels the remaining gas in the mag. I have five mags and the same issue results in each. When switching to full auto the gun will only shoot semi for 2-3 shots before the same issue occurs. As a result, I'm not even able to use full auto. The rails that guide the bolt have been filed down so I don't believe the bolt is catching something. I have fully dissembled the gun to its individual parts and cleaned and re-lubed everything and I mean everything. However, the issue still persists. Yes, I use propane in the gun but always added silicone oil. Users that I've seen using the gun with green gas are experiencing the same issues after about a few months of play. Mine have lasted 4 and 13 months respectively before the issue occurred. Not quiet sure why one lasted 13 months and the other only lasted 4 months. Seems inconsistency in the manufacturing of the guns may be an issue. (nothing comes good out of using pot metal, especially on moving parts). I'm stumped as to the cause of the problem and was seeking the advice of others who may have had or who may be experiencing this issue currently. KWA tech support would be awesome; I don't like having my guns sit on the self as show pieces.

Edited by TewMch, 30 July 2013 - 01:44 PM.


#2 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,654 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 02 August 2013 - 07:21 PM

Hi TM - Welcome to the KWA Forums.  Sorry to hear about your issues. I'm wondering if your impact block is worn out?  Perhaps the trigger transfer bar is worn also?  There are any number of issues that this can be caused by including a worn spring or two.  It's best to send the gun in for a proper repair.





Also tagged with one or more of these keywords: kmp9, issues

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users