Jump to content


kwa sr10 trigger issue (shoots without touching the trigger)


  • Please log in to reply
2 replies to this topic

#1 jorgell10

jorgell10

    Newbie

  • Members
  • Pip
  • 4 posts
  • Country:

Posted 17 June 2013 - 05:18 PM

ive been having issues with my trigger on my sr10 the trigger was getting hard on semi auto as if safe was partially enabled but then i forced the trigger and now the gun shoots by its self in full auto when you turn from safe to semi auto without touching the trigger the rifle shoots. if anybody can tell what could have gone wrong and how can i fix it i would aprecciate it. btw i am using an 11.1v lipo on it

#2 vanevery

vanevery

    Specialist

  • Members
  • PipPipPip
  • 959 posts
  • Gender:Male
  • Country:

Posted 18 June 2013 - 02:20 PM

You have a short.
Metal is touching metal somewhere in your wiring,
Start with inspecting all of the wiring from the Gearbox that runs through the Buffer Tube.
You will have to remove your stock and then Buffer Tube in order to see what you have.
Make sure these wires are not pinched at all, also.

If that does not solve it, you will need to open up your Gearbox and remove the Wiring Harness,
Clean off all the wiring, Trigger Contacts, and remove the Selector Plate for a good cleaning as well.
Inspect all the wiring.
Re-install everything mentioned above and run some electrical tests with your wiring plugged into the battery and connected to the Motor. You only need your Trigger installed and wiring components to do this, nothing else.

Try this and get back to us.

#3 niko_gpsy

niko_gpsy

    What's a Warranty?

  • Super Moderator
  • PipPipPipPip
  • 5,854 posts
  • Gender:Male
  • Location:Atlanta, GA
  • Interests:Keeping those damn squirrels from putting their filthy little paws on my peaches in my backyard. Oh, Yes. It's not just a hobby, its a passion!!
  • Country:

Posted 19 June 2013 - 08:41 AM

A short caused by stripped wiring or a pinch is a good place to look but I am wondering if you might have jammed the trigger contact block inside the two contact blades when you forced the trigger. Just a thought....................................




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users