Jump to content


What causes the bolt to lock back and stay when there are bb's still in the mag?


  • Please log in to reply
3 replies to this topic

#1 Icurblud

Icurblud

    Enthusiast

  • Members
  • PipPip
  • 101 posts
  • Gender:Male
  • Location:Pennsylvania
  • Country:

Posted 26 April 2013 - 05:04 AM

I fire a few shots and the bolt locks back.  I release and fire a few more rounds and it does it again. All the time will bb's still in the magazine.  It does it with all 3 of my mags.  Now it doesnt do it all the time but enough to be annoying.  Is it the mags?  Or is there something else I should be looking at?

#2 akiraspeedstar

akiraspeedstar

    Guru

  • Members
  • PipPipPipPip
  • 1,130 posts
  • Gender:Male
  • Country:

Posted 26 April 2013 - 06:49 AM

PMAGs? An issue I found with the PMAGs is that the magazine catch opening is too large on some of them. This allows the magazine to jump around and push the bolt stop up even when they're BBs still in the magazine. Open the receiver, insert a mag and push the magazine up. If you see the bolt stop raise than that's your issue. An easy fix is to add some epoxy to the base of the magazine catch opening on the magazine.

Another possible issue is the bolt stop plunger spring. If you've removed the impact block before you may have lost the spring or it may have lost its tension.

Edited by akiraspeedstar, 26 April 2013 - 06:50 AM.


#3 Icurblud

Icurblud

    Enthusiast

  • Members
  • PipPip
  • 101 posts
  • Gender:Male
  • Location:Pennsylvania
  • Country:

Posted 26 April 2013 - 09:19 AM

akiraspeedstar I really appriciate the input.  Yes they are PMags. I have the Magpul edition with 3 mags.  When i have a mag in and the bolt back the mag does move alot. Much more than would be expected.   You mention if i removed the impact block.  The answer is yes i have.  I know exaclty what your refering to when you say the little plunger and spring.  I know they are still in there since i made sure of it.  This give 2 positions for the lever.

#4 pingupenguins

pingupenguins

    Newbie

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:NorCal
  • Country:

Posted 10 May 2013 - 08:24 AM

I get the same problem from time to time. Usually it was because I loaded too many bb's into the mag




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users