Jump to content


hammer is stuck down


  • Please log in to reply
10 replies to this topic

#1 ATLpainter

ATLpainter

    Newbie

  • Members
  • Pip
  • 15 posts
  • Country:

Posted 06 April 2013 - 05:45 PM

hey guys the hammer is stuck down on my mp9 it will not fire i took off the upper reciever and found that if i slid this little box foreward it would let the hammer realese when you pulled the trigger but after that it remained locked afer i slid the bolt back and just did the same thing agian please help me i love my mp9 and it kills me that i cant use it

Edited by ATLpainter, 06 April 2013 - 05:47 PM.


#2 ATLpainter

ATLpainter

    Newbie

  • Members
  • Pip
  • 15 posts
  • Country:

Posted 06 April 2013 - 05:46 PM

the little thing i slid was a the bottom of the hammer one the left side

Edited by ATLpainter, 06 April 2013 - 05:47 PM.


#3 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,738 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 06 April 2013 - 06:18 PM

View PostATLpainter, on 06 April 2013 - 05:46 PM, said:

the little thing i slid was a the bottom of the hammer one the left side
Do you have a parts number of that little box and by any chance was it attached to a spring?

#4 ATLpainter

ATLpainter

    Newbie

  • Members
  • Pip
  • 15 posts
  • Country:

Posted 07 April 2013 - 01:57 PM

I ll take it apart agian and try to figure it out

#5 ATLpainter

ATLpainter

    Newbie

  • Members
  • Pip
  • 15 posts
  • Country:

Posted 07 April 2013 - 02:03 PM

Its the auctual part that holds the hammer down if i slide it foreward a little than pull the trigger it will fire when i pull the trigger

#6 ATLpainter

ATLpainter

    Newbie

  • Members
  • Pip
  • 15 posts
  • Country:

Posted 07 April 2013 - 02:07 PM

part 153 i believe it has a spring on it pulling it back the spring looks a little wore out but still pulls fine its been lubricated and appears to be moving freely with no blockages

Edited by ATLpainter, 07 April 2013 - 02:09 PM.


#7 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,738 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 07 April 2013 - 02:35 PM

See here: http://kwausa.com/im...cr_s02_kmp9.jpg

Is the bolt going all the way forward after being released?  If not, the hammer won't drop when you pull the trigger.  If that is the case, try putting a flat screw driver in part #162 (the spring) and give it (the spring) a little stretch by twisting the screwdriver.   Assuming part #153 isn't broken this may indeed solve you issue.  If part #153 is damaged or broken that's a different issue.

#8 ATLpainter

ATLpainter

    Newbie

  • Members
  • Pip
  • 15 posts
  • Country:

Posted 07 April 2013 - 03:24 PM

thanks for your help its part 153 is broken I pulled the bolt out and was able to verify that the top is broke off of that piece Im also having some trouble with my usps i posed in the usp forum

the spring looks stretched and wore out should i replace it as well while im at it?

Edited by ATLpainter, 07 April 2013 - 04:33 PM.


#9 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,738 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 07 April 2013 - 03:34 PM

View PostATLpainter, on 07 April 2013 - 03:24 PM, said:

thanks for your help its part 153 is broken i just figured it out
Yea, I was thinking that might be the issue.  You can order the part if you are comfortable with the repair or send it in.  Personally, I would send it in because any other issues you might be having can be addressed then.  You can do so by going to the Help Desk and opening a ticket.

#10 ATLpainter

ATLpainter

    Newbie

  • Members
  • Pip
  • 15 posts
  • Country:

Posted 07 April 2013 - 04:35 PM

thanks for your help its part 153 is broken I pulled the bolt out and was able to verify that the top is broke off of that piece Im also having some trouble with my usps i posed in the usp forum

the spring looks stretched and wore out should i replace it as well while im at it?

how much does it cost to send it in?

#11 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,738 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 07 April 2013 - 04:52 PM

Well you pay the shipping to KWA.  The repair, last I heard, was $35.00 with small parts being free.  The parts you need are small parts.  The return shipping was $10.00.  I would confirm these prices before sending it in so there are no surprises.  The Help Desk can do that for you.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users