Jump to content


a few HK45 questions from a newby...


  • Please log in to reply
No replies to this topic

#1 maxluger

maxluger

    Newbie

  • Members
  • Pip
  • 1 posts
  • Country:

Posted 27 February 2013 - 06:29 AM

Hi there,

Im new to this forum. .Hope you guys and girls can help me with a few problems i'm having with my KWA/ Umarex HK45 ns2 system.

Obtained this gun a couple of months ago. The first 1.000 rounds no problems what so ever.
But nowerdays it is not shooting at al...

When i load the mag with gas and BB's the first shot goes ok, the second shot goes but with little power, resulting in a weak slide action, no new bb in the chamber and the hammer half cocked. The third shot results in gas gushing out the  mag and freezing the gun up.

What could be the problem..?

at first i noticed that the gaschamber (part 135) doesnt lock in the feed ramp (part 36) correctly. There is a weak connection resulting in little resistance when the slide action works. Is this normal wear or a problem (not gastight enough??)

When the gas is gushing out i notice this happens the most at the end/ back of the slide (close the the hammer). Maybe the  gasseal (part 38) ?  Anyone has any experience with this issue ? any tricks and tips ?

Here is my final question.. I tried to remove the breach screw (part 119) but it is in there tight. What exact size hex/ Allan wrench do i need to use ? i tried metric 2,5mm and inch 7/64 but they dont seem to have the exact size.. KWA doesnt give the wrench sizes in the user manual im afraid...

Unfortunatly my gun is bought in Germany, Europe (Umarex) there fore i cant send it back to KWA USA since they dont seem to have a european support netwerk yet.. Umarex service sucks.. They dont reply to any question or request.

Edited by maxluger, 27 February 2013 - 01:31 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users