Jump to content


KWA M93r slide stuck

m93r full auto kwa pistol gbb slide stuck jams broken gas

  • Please log in to reply
6 replies to this topic

#1 darrelleman

darrelleman

    Newbie

  • Members
  • Pip
  • 15 posts
  • Country:

Posted 26 January 2013 - 08:19 AM

I was firing my m93r today when the slide got stuck like in the picture (I hope it works). It gets stuck like this when the gun is cycling forward to load another round into the hop up. As in I pull the trigger, the slide flies back but then on the way forward gets stuck. It gets stuck so I can't pull the trigger and the hammer is stuck. It isn't double feeding or anything just getting stuck. In this position the slide refuses to be pushed forward but what I can do is either pull the slide back ( at this point the bb falls out) or I can hit it with a little force and the slide goes all the way forward. I did take it apart clean it and lube it. Can someone help me fix this? Thanks!Attached File  DSCN4193.jpg   63.35K   29 downloads

#2 Outlaw1995

Outlaw1995

    Guru

  • Members
  • PipPipPipPip
  • 1,713 posts
  • Gender:Male
  • Interests:Acting, Piano, Films, Theatre, Firearms, Knives, Airsoft
  • Country:

Posted 26 January 2013 - 08:36 AM

Try cleaning and polishing the feed ramp. It looks to me that the bb gets stripped from the mag, but doesn't smoothly enter the hop up chamber, which results in it falling out when you pull the slide back again...

Have a look at that feed ramp and see if it helps.

#3 darrelleman

darrelleman

    Newbie

  • Members
  • Pip
  • 15 posts
  • Country:

Posted 26 January 2013 - 04:16 PM

I tried cleaning and lubing it. Same problem.

#4 Outlaw1995

Outlaw1995

    Guru

  • Members
  • PipPipPipPip
  • 1,713 posts
  • Gender:Male
  • Interests:Acting, Piano, Films, Theatre, Firearms, Knives, Airsoft
  • Country:

Posted 26 January 2013 - 04:49 PM

Never lubricate your feed ramp, or anything that contacts the bb for that matter. Lubricated bbs will lead that unnecessary lubrication to the hop up bucking and cause it to swell. Can you take pics of your cylinder? Are your return springs attached correctly? If the cylinder/return springs aren't the problem, then I'd send the gun in.

#5 darrelleman

darrelleman

    Newbie

  • Members
  • Pip
  • 15 posts
  • Country:

Posted 27 January 2013 - 12:48 PM

I think the cylinder and return springs are working fine but I can post a picture if you think that it could be the problem. Not sure if this helps but without a mag in the gun I can still get the slide stuck in this same position. If I push the outer barrel towards the grip of the gun it gets stuck or if I push the front of the slide the same direction. This can only happen if the hammer is locked back. I am trying to avoid sending it in if possible.

Edited by darrelleman, 27 January 2013 - 01:43 PM.


#6 darrelleman

darrelleman

    Newbie

  • Members
  • Pip
  • 15 posts
  • Country:

Posted 01 February 2013 - 01:37 PM

Anybody got any help for me?

#7 SlenderKen

SlenderKen

    Newbie

  • Members
  • Pip
  • 16 posts
  • Country:

Posted 05 March 2013 - 12:46 AM

The best thing I can suggest is lubing it too.  I have that issue with my raffica, and when I lube it, it works again.  I don't know if this works, but rumor has it that you can file down the slide so it chambers more easily.  But uhh don't take my word for it (I'm not responsible!!)
I think the M93R is a high maintenance gun, so lube up the slide every now and then, especially if you are running propane through it (It sucks the gun dry)





Also tagged with one or more of these keywords: m93r, full auto, kwa, pistol, gbb, slide, stuck, jams, broken, gas

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users