Jump to content


Bolt Not Locking (Feeder Fine!)


  • Please log in to reply
6 replies to this topic

#1 n00bguy

n00bguy

    Newbie

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Location:TN
  • Country:

Posted 27 December 2012 - 08:42 AM

I just received my MP7 on Dec. 24, 2012, and it is having problems. The first couple of days, it was working fine. On the next day, the bolt wouldn't catch. I looked online for solutions and checked my feeder, which turned out to be fine. Today, I looked more closely but couldn't see anything wrong. However, I did see that the bolt lock (part #65) wasn't moving, despite  the feeder in shape. I was wondering if anyone knew what could be causing this, so I don't have to return it or send it in for repair.

I will upload pictures of needed, but my files are too heavy right now.

Edited by n00bguy, 27 December 2012 - 09:30 AM.


#2 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,561 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 27 December 2012 - 11:19 AM

View Postn00bguy, on 27 December 2012 - 08:42 AM, said:

I just received my MP7 on Dec. 24, 2012, and it is having problems. The first couple of days, it was working fine. On the next day, the bolt wouldn't catch. I looked online for solutions and checked my feeder, which turned out to be fine. Today, I looked more closely but couldn't see anything wrong. However, I did see that the bolt lock (part #65) wasn't moving, despite  the feeder in shape. I was wondering if anyone knew what could be causing this, so I don't have to return it or send it in for repair.

I will upload pictures of needed, but my files are too heavy right now.
Can you post a picture of the BB follower?  Front and side views please.  Also, do you have more that one mag that this is happening with?

Note: Post your pictures to Photobucket and then you can copy and past the direct link into the image "window" found on the tool bar at the top of the posting page.

#3 n00bguy

n00bguy

    Newbie

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Location:TN
  • Country:

Posted 27 December 2012 - 11:32 AM

^I have a Photobucket account that I have used for years on other forums. Do I just wrap the link in [IMG][/IMG] tags (that is what I've done on other forums)?

Unfortunately, I only have one mag. My parents are already kind of out of the mood after I payed $255 for this. However, if I can get a refund, then I'll be able to get the 2-mag package from ASGI.

On a side note, about how many three-second 'bursts' (I can't remember what you call it) of air should I have to do to completely fill the mag with GG? I jut got my 1000ml can of GG and I've given each filling about 4-8 burst, trying not to use it completely up, abd i get about a half to one and a half mags. So far I've put about 15-20 fillings in, and my can is acting like its empty, and my mag acts like its full. Is this normal for winter? I feel like I am wasting my GG way to quickly, and my begun is getting the best efficiency that I've been told it will get in winter.

Edited by n00bguy, 27 December 2012 - 11:44 AM.


#4 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,561 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 27 December 2012 - 11:38 AM

You can try posting as you describe above.  I have always simply cut and pasted the link to image window found in the tool bar.

#5 n00bguy

n00bguy

    Newbie

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Location:TN
  • Country:

Posted 27 December 2012 - 11:56 AM

As you can see, the bb follower is fine (otherwise I would have had this solved earlier):
Posted Image
Posted Image

Do you mind taking a look back at post #3 and responding to what I edited in (I don't want to have to repeat that in case you missed it)?

Edited by n00bguy, 27 December 2012 - 12:07 PM.


#6 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,561 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 27 December 2012 - 02:19 PM

View Postn00bguy, on 27 December 2012 - 11:32 AM, said:

^I have a Photobucket account that I have used for years on other forums. Do I just wrap the link in <img src="" /> tags (that is what I've done on other forums)?

Unfortunately, I only have one mag. My parents are already kind of out of the mood after I payed $255 for this. However, if I can get a refund, then I'll be able to get the 2-mag package from ASGI.

On a side note, about how many three-second 'bursts' (I can't remember what you call it) of air should I have to do to completely fill the mag with GG? I jut got my 1000ml can of GG and I've given each filling about 4-8 burst, trying not to use it completely up, abd i get about a half to one and a half mags. So far I've put about 15-20 fillings in, and my can is acting like its empty, and my mag acts like its full. Is this normal for winter? I feel like I am wasting my GG way to quickly, and my begun is getting the best efficiency that I've been told it will get in winter.
First the GG question - I fill mine till I no longer hear gas filling in the mag.  That's probably 20 seconds.  When in doubt go longer...If you are getting less than a full mag dump at room temp then the can is too empty to fill the mag.  GG cans are notorious for feeling like there is enough gas in them to fill the mag and then not doing so.  Also, there is a brand of GG called Power Green that uses a screw on fill adapter.  In my experience they do not work well at all in KWA's or other brands for that matter including TM.  For this reason I always recommend a brand like KWA or KA that has an integrated fill nozzle.

Bolt not locking - With the bolt held open, insert the empty mag.  While doing so look in against the far wall of the chamber.  There is a bar part #41 "Bolt Catch Lever" there that should move "up" as you insert the mag.  If this doesn't happen then there is either something preventing the BB follower from engaging or that part is damaged.

#7 n00bguy

n00bguy

    Newbie

  • Members
  • Pip
  • 4 posts
  • Gender:Male
  • Location:TN
  • Country:

Posted 27 December 2012 - 02:50 PM

^Yes, that is my problem. When I looked at it earlier today, I saw that the lever wasn't moving, even though the bb follower is fine. I'm not sure what it is, but something is causing it to not work.

Edited by n00bguy, 27 December 2012 - 02:59 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users