Jump to content


Whats Going On With My ATP?!


  • Please log in to reply
2 replies to this topic

#1 lukearsenault

lukearsenault

    Newbie

  • Members
  • Pip
  • 1 posts
  • Country:

Posted 17 November 2012 - 02:23 PM

I just got the ATP and the first 15ish minutes used it everything was amazing.  However, now the slide stops when the slide is halfway through the cycle after it shoots a BB.  Also, it releases all of the gas out of the barrel when i manually push the slide to the normal position.  Is the problem the cold or do i need to put silicon oil on a certain part?

#2 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,565 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 17 November 2012 - 04:11 PM

Hi Lukearsenault, welcome to the KWA Forums.  Is this a new gun?  If so, you may want to bring it to the shop for a quick diagnostic.  If the gun isn't new, or you can't bring it to the shop, I would do the following:

For the Slide Issue
  • Field strip

  • Clean the rails and all moving parts that you can with a cotton swab

  • LIGHTLY re-lube

  • Test the gun
Also, are you using green gas or propane?  If you are using propane, sometime the gun can foul from residue.  This probably isn't the case with your gun though given the fact it has been used for a short amount of time.  Rather, when you add silicone to the propane, adding too much can cause dirt to be attracted to the side and rails and then the gun jams up.

For the Gas Dumping
This is more troubling and why I asked if it is a new gun.  The older ATPs suffered from this because of some internal parts that needed a bit of breaking in.  You can do this in yours, new or old, by adding silicone oil to the hammer assembly and working the hammer 30-40 times.  Field strip the gun first, clean out and dirt, lube, actuate the hammer, reassemble and test.

Please note: All testing should be done at room temp to ensure the cold is no issue.

If the problems continue, you can send the gun to KWA for repair.

Hope this helps.

#3 Outlaw1995

Outlaw1995

    Guru

  • Members
  • PipPipPipPip
  • 1,713 posts
  • Gender:Male
  • Interests:Acting, Piano, Films, Theatre, Firearms, Knives, Airsoft
  • Country:

Posted 18 November 2012 - 07:33 AM

GCW's solution is probably what you need, but here's another thing that I've noticed with this issue: Does your nozzle stick out and stay in place when the slide goes back? If so, check your seal on the top of your magazine behind the feed lips. I've seen that the new-in-box mag's nozzle seal (part MG12) may have a rare tendency to tear and prevent the nozzle from fulling returning backward, causing the malfunction. This probably isn't the case with your gun, but it's always good to have options.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users