Jump to content


USP tactical using way too much gas per shot


  • Please log in to reply
12 replies to this topic

#1 xzivr

xzivr

    Newbie

  • Members
  • Pip
  • 5 posts
  • Country:

Posted 19 November 2012 - 08:46 PM

Hey all,

I have a USP Tactical that I bought a few months ago but haven't had the chance to use too much. I brought it out today to fire a couple mags through it, and noticed something's wrong. The first couple of shots seem to be normal (though I noticed a big cloud of gas) and then the power quickly trails off, until the gun won't cycle and the magazine still has ~half its BBs left.

This is the NS2 system and is completely stock except for an NPAS valve, which worked fine last I tested, and is tuned to about 270 FPS. Took it all apart and verified all the internal parts were moving freely, and they are, but beyond that..

Any ideas? I'm really not that good with gas guns yet, no idea where to even start on this one.. Any help appreciated!

Edited by xzivr, 19 November 2012 - 09:20 PM.


#2 Outlaw1995

Outlaw1995

    Guru

  • Members
  • PipPipPipPip
  • 1,713 posts
  • Gender:Male
  • Interests:Acting, Piano, Films, Theatre, Firearms, Knives, Airsoft
  • Country:

Posted 20 November 2012 - 03:13 PM

How long are you filling your magazine with gas for? Try filling for at least 20 seconds and see if that makes a difference, also try getting a new bottle of green gas and see if that solves the issue, your old can may be running out, maybe there's a loss in pressure in the can...

#3 xzivr

xzivr

    Newbie

  • Members
  • Pip
  • 5 posts
  • Country:

Posted 20 November 2012 - 06:23 PM

I made sure to hold the thing on there for at least that long, always do. It's a relatively new bottle, too, but just to be sure I tried it on my GBBR and no issues there.

#4 Outlaw1995

Outlaw1995

    Guru

  • Members
  • PipPipPipPip
  • 1,713 posts
  • Gender:Male
  • Interests:Acting, Piano, Films, Theatre, Firearms, Knives, Airsoft
  • Country:

Posted 20 November 2012 - 06:28 PM

Check if your magazine is leaking in any way. You can check by submersing an empty mag in water and see if any bubbles come from the mag.

You may have to tighten the gas release and charging valves, as well as lubricate all the o rings with 100% pure silicon oil to ensure a tight seal.

#5 xKingSizex

xKingSizex

    Customer Service Manager

  • Administrators
  • PipPipPipPip
  • 1,821 posts
  • Gender:Male
  • Location:Long Beach, CA
  • Interests:Umm, airsoft...
  • Country:

Posted 21 November 2012 - 10:02 AM

Have you tried putting the stock parts back in and testing it again?

#6 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,650 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 21 November 2012 - 03:38 PM

View PostxKingSizex, on 21 November 2012 - 10:02 AM, said:

Have you tried putting the stock parts back in and testing it again?
Dotto that...

#7 Harbinger of Darkness

Harbinger of Darkness

    Newbie

  • Members
  • Pip
  • 4 posts
  • Country:

Posted 27 January 2013 - 02:12 PM

Another Canadian here having the same issue out of the box. No aftermarket parts installed fresh can of green gas and I only get two to three shots before i'm out of gas. I am also an area gun doc and for the life of me can't figure out what the cause of issue is. The magazine holds gas just fine. I've stripped and re-lubed everything. Anyone have any ideas?

#8 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,650 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 27 January 2013 - 02:23 PM

View PostHarbinger of Darkness, on 27 January 2013 - 02:12 PM, said:

Another Canadian here having the same issue out of the box. No aftermarket parts installed fresh can of green gas and I only get two to three shots before i'm out of gas. I am also an area gun doc and for the life of me can't figure out what the cause of issue is. The magazine holds gas just fine. I've stripped and re-lubed everything. Anyone have any ideas?
Hi H of D - Welcome to the KWA forums....Any chance you can do a video showing the mag being filled, and the gun being shot?  Do you have more than one mag to test?

#9 Harbinger of Darkness

Harbinger of Darkness

    Newbie

  • Members
  • Pip
  • 4 posts
  • Country:

Posted 27 January 2013 - 02:57 PM

I can indeed make a video. Unfortunately I only have the original mag, 2 more should be coming in about 1-2 weeks. I will make a video and upload it for you.

#10 Harbinger of Darkness

Harbinger of Darkness

    Newbie

  • Members
  • Pip
  • 4 posts
  • Country:

Posted 27 January 2013 - 03:12 PM

Video uploaded. https://www.youtube....h?v=FDTyuPO8DbE

#11 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,650 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 27 January 2013 - 03:43 PM

View PostHarbinger of Darkness, on 27 January 2013 - 03:12 PM, said:

New can of gas, yes?  Have you or can you try another?  If that's not it, I am wondering if the fill valve is damaged?  If that's the case a new fill valve would fix it and they aren't really expensive.

#12 Harbinger of Darkness

Harbinger of Darkness

    Newbie

  • Members
  • Pip
  • 4 posts
  • Country:

Posted 27 January 2013 - 04:37 PM

Brand new can. I've tried 3 now (2 green gas and one propane with adaper). I have a feeling it's the gun itself. I've opened a warranty ticket . Hopefully this will get resolved soon. I've never had an issue with an out of box KWA before.

#13 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,650 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 27 January 2013 - 05:14 PM

View PostHarbinger of Darkness, on 27 January 2013 - 04:37 PM, said:

Brand new can. I've tried 3 now (2 green gas and one propane with adaper). I have a feeling it's the gun itself. I've opened a warranty ticket . Hopefully this will get resolved soon. I've never had an issue with an out of box KWA before.
Warranty ticket is best for this one.  I'm sure it will be resolved quickly.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users