Jump to content


Leaking M93R NS2 magazines


  • Please log in to reply
5 replies to this topic

#1 RayL

RayL

    Newbie

  • Members
  • Pip
  • 14 posts
  • Gender:Male

Posted 05 April 2009 - 06:38 PM

About 2 weeks ago I ordered an M93R (NS2 Version) and two magazines to go with it. Upon arrival the two magazines were slightly leaking from the bottom, I didn't think much of it since it was a small leak.

Yesterday after a week of non-usage, I decided to fill them, and after filling them I turned them right side up and the gas just escaped out the bottom of the mags (from in between the base plate and the magazine), you could actually see the gas spray every time I turn the magazines over after filling them. They won't hold any gas and are unusable. I tried tightening the fill valve and adding silicone oil to the fill area as well, but didn't work.

The magazine included with the gun works great, which leads me to believe the other two were defective or something. Again, I only used the magazines 1 day and were already leaking when filled.

I was planning to purchase a KWA M9 PTP tactical and  two extra magazines next, but after this I'm not too sure if I will.

Are gas gun magazines under any warranty from KWA, or is there something I can do to fix them?

#2 Warlord

Warlord

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 06 April 2009 - 04:22 PM

The mag that came with my PTP M9 was leaking pretty good when I first got it, too.  I just disassembled it and relubed part#908 (Magazine parts diagram) with silicone oil and tightened everything back up.  Works perfectly now.  I also picked up a high- cap M93R mag for my PTP for when I finally get that locking block fixed.  The M93r mag worked perfect on day 1 without any leaks...

The bottom valve unscrews with a #4 spanner bit.

View PostRayL, on Apr 5 2009, 09:38 PM, said:

About 2 weeks ago I ordered an M93R (NS2 Version) and two magazines to go with it. Upon arrival the two magazines were slightly leaking from the bottom, I didn't think much of it since it was a small leak.

Yesterday after a week of non-usage, I decided to fill them, and after filling them I turned them right side up and the gas just escaped out the bottom of the mags (from in between the base plate and the magazine), you could actually see the gas spray every time I turn the magazines over after filling them. They won't hold any gas and are unusable. I tried tightening the fill valve and adding silicone oil to the fill area as well, but didn't work.

The magazine included with the gun works great, which leads me to believe the other two were defective or something. Again, I only used the magazines 1 day and were already leaking when filled.

I was planning to purchase a KWA M9 PTP tactical and  two extra magazines next, but after this I'm not too sure if I will.

Are gas gun magazines under any warranty from KWA, or is there something I can do to fix them?


#3 RayL

RayL

    Newbie

  • Members
  • Pip
  • 14 posts
  • Gender:Male

Posted 06 April 2009 - 08:27 PM

View PostWarlord, on Apr 6 2009, 05:22 PM, said:

The bottom valve unscrews with a #4 spanner bit.

Can I just use a flat head screwdriver?

Thanks, I might try that. I purchased them online and didn't want to disassemble anything yet so I wouldn't void my warranty. I was thinking I could return them and have them fix them or send me new ones.

I see this board is rather dead... No one seems to want to help. Only those with problems are helping each other.

Thanks anyway Warlord.

#4 Spiggy

Spiggy

    Member

  • Members
  • PipPipPipPip
  • 2,136 posts
  • Gender:Male
  • Location:City of Industry
  • Country:

Posted 20 April 2009 - 11:31 AM

:P there are only so many of us technicians, and I'm at work half the time.

Yep, PM me your info, I'll take care of ya

#5 RayL

RayL

    Newbie

  • Members
  • Pip
  • 14 posts
  • Gender:Male

Posted 20 April 2009 - 12:54 PM

View PostSpiggy, on Apr 20 2009, 12:31 PM, said:

:P there are only so many of us technicians, and I'm at work half the time.

Yep, PM me your info, I'll take care of ya

Thanks for the response Spiggy, I fixed the magazines myself by opening them and removing the inside seal (KWA part #14). I applied some silicone oil on one them and re-assembled the magazines, they work perfectly now. The seals were also stuck and needed to be set into place.

#6 Spiggy

Spiggy

    Member

  • Members
  • PipPipPipPip
  • 2,136 posts
  • Gender:Male
  • Location:City of Industry
  • Country:

Posted 20 April 2009 - 03:00 PM

Sure, if you want a direct response next time, try posting a question in help desk.




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users