Jump to content


Trigger reset issue


  • Please log in to reply
6 replies to this topic

#1 sburgess64

sburgess64

    Newbie

  • Members
  • Pip
  • 1 posts
  • Country:

Posted 27 December 2013 - 08:59 PM

My Kriss Vector's trigger is not resetting sometimes when I shoot, thus when I pull the trigger nothing happens and after a second I hear it reset itself. So something is wrong with the trigger resetting.

#2 jayrod9727

jayrod9727

    Enthusiast

  • Members
  • PipPip
  • 43 posts
  • Gender:Male
  • Country:

Posted 28 December 2013 - 09:02 PM

Sounds like your going to have to pull the trigger box apart and find the problem. How old is the gun and how many shots do you have threw it? I hope you don't need parts because odds are your not going to find them here. Looks like KWA is more into selling guns not parts and that's a shame they can't support their product.

Edited by jayrod9727, 28 December 2013 - 09:09 PM.


#3 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,310 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 29 December 2013 - 09:50 AM

View Postjayrod9727, on 28 December 2013 - 09:02 PM, said:

Sounds like your going to have to pull the trigger box apart and find the problem. How old is the gun and how many shots do you have threw it? I hope you don't need parts because odds are your not going to find them here. Looks like KWA is more into selling guns not parts and that's a shame they can't support their product.
Regarding parts, KWA has 3 pages of parts listed for sale in the Pro-Shop for the Vector: http://store.kwausa....orsmgparts.aspx

And while all parts aren't listed, the most commonly needed ones typically are.  If a particular part isn't listed, it is most likely available for an RMA repair.

#4 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,310 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 29 December 2013 - 09:51 AM

View Postsburgess64, on 27 December 2013 - 08:59 PM, said:

My Kriss Vector's trigger is not resetting sometimes when I shoot, thus when I pull the trigger nothing happens and after a second I hear it reset itself. So something is wrong with the trigger resetting.
How old is your Vector and are you the original owner?

#5 jayrod9727

jayrod9727

    Enthusiast

  • Members
  • PipPip
  • 43 posts
  • Gender:Male
  • Country:

Posted 29 December 2013 - 11:25 AM

Just because you list parts doesn't mean anything. You have NO stock on parts that will render the gun useless. I even called you guys and asked when they would be in and you had NO Idea.
Example of parts that you have not stocked for sometime and these parts from what I have read on other forums seem to fail often and would explain the shortage #53, #55, #60 and #304. Not to mention the parts you don't even carry the small roll pins #516 and #518 these pins are tiny and if you loose or damage one  you will be SOL.  
Don't get me wrong the Kriss is IMO the Best GBB SMG ever produced. Just would like to see more parts available.

Edited by jayrod9727, 29 December 2013 - 11:57 AM.


#6 Mark808

Mark808

    Newbie

  • Members
  • Pip
  • 1 posts
  • Country:

Posted 22 January 2014 - 12:29 PM

I have this issue also, I once took off the trigger box and put it back it, and the trigger reset worked temp. The hammer seems to be have resistant to push back on the starting postion on my Kriss, it's more likly lubing problem, but I don't know.

Edited by Mark808, 22 January 2014 - 01:09 PM.


#7 Echo5

Echo5

    Newbie

  • Members
  • Pip
  • 5 posts
  • Country:

Posted 04 February 2014 - 10:45 AM

3rd mag through the gun, and yes I lubed it up, and I have the same problem. Also, it seems that it happens more as I get towards the end of the mag which made me think that has something to due with gas consumption.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users