Jump to content


Mark Iv 1911's Saftey Doesn't Work....


  • Please log in to reply
10 replies to this topic

#1 iAteChoChild

iAteChoChild

    Newbie

  • Members
  • Pip
  • 5 posts
  • Country:

Posted 06 April 2011 - 03:45 PM

Hi everyone,
I just bought a Mark IV and the safety doesnt work. its weird because i also have the Mark II and the safety works perfectly on it. when i click it up, i pull the trigger and its tight and wont move. On the Mark IV, when i put the safety on, i pull the trigger and it just takes a little more effort to pull the trigger, then *click*, the hammer goes down. then i can pull down the hammer even though the safety is on, and keep firing. Normally i wouldn't care because i rarely use the safety anyway, but the thing is, if i turn the safety on by accident and i pull the trigger in an actual game, it will shoot but the slide wont cycle. kind of a bummer.   :(  If you know whats goin on, please tell me.
Thanks in advance!

#2 MrMonkekekeMan

MrMonkekekeMan

    Enthusiast

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:NY
  • Interests:Airsoft, KWA LM4
  • Country:

Posted 07 April 2011 - 12:50 AM

When you put the safety on was the hammer down?

#3 iAteChoChild

iAteChoChild

    Newbie

  • Members
  • Pip
  • 5 posts
  • Country:

Posted 07 April 2011 - 08:54 AM

View PostMrMonkekekeMan, on 07 April 2011 - 12:50 AM, said:

When you put the safety on was the hammer down?

I've tried it all, pulling back the hammer then putting the safety on, keeping the hammer forward and putting the safety on and then pulling back the hammer while the safety is on (which shouldn't be able to happen). the only time the trigger will not move is if the hammer is half cocked.

#4 MrMonkekekeMan

MrMonkekekeMan

    Enthusiast

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:NY
  • Interests:Airsoft, KWA LM4
  • Country:

Posted 07 April 2011 - 11:24 AM

Ok tell me this: When you have the hammer down anda try to put the safety on does it go all the way on or does it stop halfway?

#5 iAteChoChild

iAteChoChild

    Newbie

  • Members
  • Pip
  • 5 posts
  • Country:

Posted 10 April 2011 - 03:31 PM

View PostMrMonkekekeMan, on 07 April 2011 - 11:24 AM, said:

Ok tell me this: When you have the hammer down anda try to put the safety on does it go all the way on or does it stop halfway?

It goes all the way up.

#6 MrMonkekekeMan

MrMonkekekeMan

    Enthusiast

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:NY
  • Interests:Airsoft, KWA LM4
  • Country:

Posted 11 April 2011 - 01:04 PM

Well thats your problem right there. Don't do that with any GBB or real firearm. The hammer usually has to be cocked before that safety can be engaged. It sounds like your safety lever has broken from you trying to put it on without the hammer cocked. You probably need a new safety lever.

#7 iAteChoChild

iAteChoChild

    Newbie

  • Members
  • Pip
  • 5 posts
  • Country:

Posted 12 April 2011 - 02:49 PM

View PostMrMonkekekeMan, on 11 April 2011 - 01:04 PM, said:

Well thats your problem right there. Don't do that with any GBB or real firearm. The hammer usually has to be cocked before that safety can be engaged. It sounds like your safety lever has broken from you trying to put it on without the hammer cocked. You probably need a new safety lever.

Well actually, when I bought the gun, it was like that. I even tried switching the safety out from my Mark II. that didnt work either. Then i tried switching the entirety of the internals. not even that worked. Its a frame issue. Something on the frame is damaged. its just a bummer since i cant get the warranty because the Airsoft store i bought it from had it longer than 40 days.  :(

#8 SR105

SR105

    Tech

  • KWA Staff
  • PipPip
  • 170 posts
  • Gender:Male
  • Location:Walnut, CA
  • Country:

Posted 26 April 2011 - 05:42 AM

KWA warranty is from date of purchase, not how long the retailer has had it unless the place you bought the MKII is not an authorized KWA dealer. Where did you buy it and how long has it been?

#9 h45223

h45223

    Newbie

  • Members
  • Pip
  • 3 posts
  • Country:

Posted 11 November 2011 - 09:42 PM

Hello, I have the reverse problem.  After cocking the hammer, I can't put the thumb safety on.  It doesn't go all the way.  Can this also be the safety lever?  I just bought the Mk IV 1911 last week from Evike.  It shoots fine.  Thanks for any input.

#10 h45223

h45223

    Newbie

  • Members
  • Pip
  • 3 posts
  • Country:

Posted 12 November 2011 - 12:08 AM

Well, I don't know what I did but while tinkering around, the safety now works.  Must have been operator error.  Sorry about the false alarm guys.

#11 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,720 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 12 November 2011 - 07:59 AM

Welcome to the forum and happy to hear that all worked out for you.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users