Jump to content


im haveing electrical issues with my m4.


  • Please log in to reply
9 replies to this topic

#1 kevink

kevink

    Newbie

  • Members
  • Pip
  • 4 posts
  • Country:

Posted 19 December 2013 - 06:13 PM

just bought kwa m4 cqr mod1 magpul moe aeg rifle worked fine then stoped battery is 9.6v 1600mah tested and is good checked inline fuse good wiggled the wires work for a sec then dead? do i try to fix this or send it back to kwa? any help would be much appreciated.

#2 tales

tales

    Specialist

  • Members
  • PipPipPip
  • 562 posts
  • Gender:Male
  • Location:Brooklyn NY
  • Interests:Fishing, RC cars, Building Motion Picture sets
  • Country:

Posted 19 December 2013 - 07:43 PM

Welcome!

Did you "wiggle" the wires near the tamiya connectors?
these
Posted Image

If yes you might want to try Deans connectors WSDeans, not the knock offs they do come apart.

For the gun & charger
http://www.ebay.com/...=item53f979a8b1

For the battery's
http://www.ebay.com/...=item1e7b6e0160

Edited by tales, 19 December 2013 - 07:44 PM.


#3 kevink

kevink

    Newbie

  • Members
  • Pip
  • 4 posts
  • Country:

Posted 19 December 2013 - 09:26 PM

View Posttales, on 19 December 2013 - 07:43 PM, said:

Welcome!

Did you "wiggle" the wires near the tamiya connectors?
these
Posted Image

If yes you might want to try Deans connectors WSDeans, not the knock offs they do come apart.

For the gun & charger
http://www.ebay.com/...=item53f979a8b1

For the battery's
http://www.ebay.com/...=item1e7b6e0160
yes i did no luck. thank you for your input but i think its more serious then a loose wire. kinda sounded like something seized up motor or piston? just a guess. may have the tech at tac city look at it before sending it back.

#4 iWar

iWar

    Enthusiast

  • Members
  • PipPip
  • 82 posts
  • Gender:Male
  • Location:NH
  • Interests:Racing at the track, Music, Airsoft, playing sports, and anything that is fun...
  • Country:

Posted 20 December 2013 - 08:04 AM

Try testing the motor out of the gun or in another gun. Sometimes the kwa motors crap out. Happened to me the first time I played with my SR10. Sent it back and has worked great for me ever since. I've put about 100K rounds threw it since then...

#5 kevink

kevink

    Newbie

  • Members
  • Pip
  • 4 posts
  • Country:

Posted 20 December 2013 - 08:53 AM

Thanks ill try that. :-)

#6 tales

tales

    Specialist

  • Members
  • PipPipPip
  • 562 posts
  • Gender:Male
  • Location:Brooklyn NY
  • Interests:Fishing, RC cars, Building Motion Picture sets
  • Country:

Posted 20 December 2013 - 11:41 AM

This might help
http://www.kwausa.co...164#entry101598

#7 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,736 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 20 December 2013 - 04:17 PM

View Postkevink, on 19 December 2013 - 09:26 PM, said:

yes i did no luck. thank you for your input but i think its more serious then a loose wire. kinda sounded like something seized up motor or piston? just a guess. may have the tech at tac city look at it before sending it back.
So the gun is making a noise but the gearbox won't cycle?  And...Magpul MOE, who did the modifications?  Was this purchased new or second hand?

#8 Chuck S

Chuck S

    Guru

  • Members
  • PipPipPipPip
  • 1,360 posts
  • Gender:Male
  • Location:Cleveland, Ohio
  • Country:

Posted 21 December 2013 - 04:26 AM

If this is new and in warranty I'd send it to KWA for a proper repair or adjustment.  These guys not only have the technical skills they have the parts.  Now that I wrote that I'd send it to them regardless of being in warranty.

-- Chuck

#9 kevink

kevink

    Newbie

  • Members
  • Pip
  • 4 posts
  • Country:

Posted 22 December 2013 - 10:20 AM

yeah thanks for everyones advice. at this point I think the best thing to do is send it back to Kwa for warranty service before it runs out.

#10 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,736 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 22 December 2013 - 12:26 PM

View Postkevink, on 22 December 2013 - 10:20 AM, said:

yeah thanks for everyones advice. at this point I think the best thing to do is send it back to Kwa for warranty service before it runs out.
Definitely the best option.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users