Jump to content


M11 Ns2 Gas Efficiency Issues


  • Please log in to reply
13 replies to this topic

#1 LoganDoan

LoganDoan

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 22 March 2011 - 11:05 AM

Just got a used M11, with 4 mags. all mags can't do a mag dump in full auto. Yes, I'm sure it's the NS2 version. It's about 70f outside.

Any ideas? Green Gas and propane have the same results. I tried lubing what I could with 100% pure spray silicon.

Otherwise, the gun functions great and is a blast. Any ideas lads?

#2 AdamMF

AdamMF

    Newbie

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Country:

Posted 23 March 2011 - 02:56 PM

Im not sure, check the rubber seals on the mags and bolt. I think when they get worn, you will lose some efficiency.

Just a thought.

#3 Spiggy

Spiggy

    Member

  • Members
  • PipPipPipPip
  • 2,136 posts
  • Gender:Male
  • Location:City of Industry
  • Country:

Posted 23 March 2011 - 03:41 PM

spray silicone tells me that something is now out of specification

#4 LoganDoan

LoganDoan

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 23 March 2011 - 03:58 PM

View PostSpiggy, on 23 March 2011 - 03:41 PM, said:

spray silicone tells me that something is now out of specification


Yeah, it's all I had left.. but I didn't lube anything until after I realized there were issues.

#5 Spiggy

Spiggy

    Member

  • Members
  • PipPipPipPip
  • 2,136 posts
  • Gender:Male
  • Location:City of Industry
  • Country:

Posted 24 March 2011 - 03:31 PM

first and foremost, need to determine your location

#6 LoganDoan

LoganDoan

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 24 March 2011 - 03:43 PM

Hershey, PA.

#7 HBNorm

HBNorm

    Newbie

  • Members
  • Pip
  • 13 posts
  • Country:

Posted 11 April 2011 - 09:09 PM

I'm in Huntington Beach California and I have the same problem here even when it's in the 80's.  Same with all of my clips.  If you dump the mag at full auto, the clip cools down too much and it peters out.  If you go in small bursts you might make it through the whole clip...if you're lucky...  My other NS2 guns work great.  The Mac 11 is awesome but the efficiency isn't that great.  Seems like a common issue from others that I know that own the Mac.

Norm

#8 greatwatermelon

greatwatermelon

    I Break GUNS!

  • Members
  • PipPipPipPip
  • 1,078 posts
  • Gender:Male
  • Location:Irvine, CA
  • Country:

Posted 13 April 2011 - 01:49 AM

I get 1.5x mags worth of gas for my m11 ns2's 2 magazines. Even though I'm not familiar with this gas inefficiency, I constantly maintain my m11 with the 100% silicone oil (non-spray) and stick to green gas.

#9 maaghimself

maaghimself

    Newbie

  • Members
  • Pip
  • 1 posts
  • Country:

Posted 12 June 2011 - 06:54 PM

Anybody have any ideas or got any updates on this? I'm having the same exact problems on my m11. It's not even a month old. Fires fine on semi/ small bursts, but can't dump a mag in full auto. I use propane, but the gun is always thoroughly cleaned and lubed with 100% non spray silicone. Ambient temps around 80F.

Edited by maaghimself, 12 June 2011 - 07:04 PM.


#10 gunsmoke7.62

gunsmoke7.62

    Newbie

  • Members
  • Pip
  • 13 posts
  • Country:

Posted 17 January 2012 - 08:17 PM

I just purchased one tonight when I got home I shot it 1 mag without lube and it did not make it through the magazine. Should I return it?

#11 philsaudio

philsaudio

    Enthusiast

  • Members
  • PipPip
  • 277 posts
  • Gender:Male
  • Location:Atlanta
  • Interests:Playing Bass, Grandkids, camping
  • Country:

Posted 18 January 2012 - 08:10 AM

I was asking about upgrading the recoil spring in my ATP. One of the negatives of getting stronger blow back from the stronger recoil spring is worse gas efficiency. I am getting 3-4 clips on a mag now so I decided I dont need more kick.

#12 gunsmoke7.62

gunsmoke7.62

    Newbie

  • Members
  • Pip
  • 13 posts
  • Country:

Posted 01 February 2012 - 09:55 AM

This is the least helpful forum I have ever been on. I only purchased KWA because I thought they had superior products and service and from my experience so far neither is true! KWA better step it up or I might start telling my story on other forums. I got a brand new gun that does not work properly out of the box and I cant get a response on how to fix it. UNACCEPTABLE! If I could return this thing I would.

#13 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,310 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 01 February 2012 - 07:58 PM

View Postgunsmoke7.62, on 01 February 2012 - 09:55 AM, said:

This is the least helpful forum I have ever been on. I only purchased KWA because I thought they had superior products and service and from my experience so far neither is true! KWA better step it up or I might start telling my story on other forums. I got a brand new gun that does not work properly out of the box and I cant get a response on how to fix it. UNACCEPTABLE! If I could return this thing I would.
Sorry that you are having troubles.  I just re-read your post.  Please explain what you mean by "without lube"?  Are you shooting with propane or green gas?  How long did you charge the mag?  They need to be charged for about 20+ seconds.  Also, what ever gas you are using, were you in a cold environment and was the can of gas you used new?  Lastly, where did you buy the gun?

#14 greatwatermelon

greatwatermelon

    I Break GUNS!

  • Members
  • PipPipPipPip
  • 1,078 posts
  • Gender:Male
  • Location:Irvine, CA
  • Country:

Posted 03 February 2012 - 02:12 AM

View Postgunsmoke7.62, on 01 February 2012 - 09:55 AM, said:

This is the least helpful forum I have ever been on. I only purchased KWA because I thought they had superior products and service and from my experience so far neither is true! KWA better step it up or I might start telling my story on other forums. I got a brand new gun that does not work properly out of the box and I cant get a response on how to fix it. UNACCEPTABLE! If I could return this thing I would.

Next time if you do not receive a response even after a day, feel free to PM any of us mods or staff directly, or even start your own thread. We go through various parts of the forum, and sometimes we miss a reply or concern. If that does not satisfy you either, KWA can be contacted directly during the day. 5 full workdays a week.

As for you problems, the same concerns are the questions that GCW asked above. There are many variables that can go into your M11A1's lack of performance. A nearly empty can not providing enough pressure, or a leaky valve, or the problems with using propane, or a cracked cylinder or temperature of the room. There are many variables and we need to give us more information.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users