Jump to content


Kwa 120 MidcapsWont feed


  • Please log in to reply
24 replies to this topic

#1 rgjeep

rgjeep

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Lake Elsinore
  • Interests:Airsoft, milsim, four wheeling and real steel
  • Country:

Posted 10 March 2014 - 06:18 AM

Little background first , I have a Kwa Mod 2 Cqr and thought it would be a great idea to use the midcaps as i don not like having to wind high caps. This is the second time out that i have had issues with the 120s not wanting to feed. I have tried high caps and they feed flawlessly, I have had the gun lookedc at by a tech and everything is in proper order. I shoot either TSD or Lancer Tactical .25s and have never had an issue. It seems like the springs are weak and they are not pushing up all the way. I have 9 mags and all of them are doing the same thing. And no I dont store them loaded , and i only loaded like 80 rounds the first couple of times to break them in as i have read in m,any seperate places. This is very disenheartening as i have spent 12 bucks per mag just to be frustrated.  Any help would be appreciated. I am open to suggestions........

#2 BLATEY

BLATEY

    Enthusiast

  • Members
  • PipPip
  • 138 posts
  • Gender:Male
  • Location:Iowa City, Iowa
  • Interests:Keepin' it Real.
  • Country:

Posted 10 March 2014 - 06:29 AM

How long have you had the gun for? If it's still under warranty than you should return it to your supplier or have kwa look at it

#3 Rain Man

Rain Man

    Enthusiast

  • Members
  • PipPip
  • 109 posts
  • Gender:Male
  • Interests:Airsoft (obviously). Gaming. Baseball. Fantasy Football. Skiing
  • Country:

Posted 10 March 2014 - 06:54 AM

I also have a CQR and i had the same issue when i first got my K120 with it. D boys huh caps would work fine, but the K120's wouldn't. Have you opened the magazines yet? I opened mine up, cleaned and lubricated the BB track, reassembled it, and i haven't had any more issues since. Also, you could return them if your warranty is still good, although they could be fixable.

Edited by Rain Man, 10 March 2014 - 06:55 AM.


#4 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,509 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 10 March 2014 - 09:46 AM

View Postrgjeep, on 10 March 2014 - 06:18 AM, said:

Little background first , I have a Kwa Mod 2 Cqr and thought it would be a great idea to use the midcaps as i don not like having to wind high caps. This is the second time out that i have had issues with the 120s not wanting to feed. I have tried high caps and they feed flawlessly, I have had the gun lookedc at by a tech and everything is in proper order. I shoot either TSD or Lancer Tactical .25s and have never had an issue. It seems like the springs are weak and they are not pushing up all the way. I have 9 mags and all of them are doing the same thing. And no I dont store them loaded , and i only loaded like 80 rounds the first couple of times to break them in as i have read in m,any seperate places. This is very disenheartening as i have spent 12 bucks per mag just to be frustrated.  Any help would be appreciated. I am open to suggestions........
Hi Rgjeep - Welcome to the KWA Forums.  I would return these for warranty repair or placement as long as they are still within the 45 day warranty.  I am assuming that the mags are not jamming. Rather, they are not properly engaging and thus causing the issue.  Please confirm?  If this is the case, and they are outside of the warranty, there are a few things to consider that might help:
  • If you have added a ranger plate to them then they may encounter an issue where they will not feed.  Some shim material under the plate should resolve this
  • I have heard that you can shave about 1mm of material off the plastic piece that retails the BB's in the mag while it is out of the magwell.  If this piece is not retracting enough then this can cause feeding issues
Hope this helps.

#5 rgjeep

rgjeep

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Lake Elsinore
  • Interests:Airsoft, milsim, four wheeling and real steel
  • Country:

Posted 10 March 2014 - 05:37 PM

Yes they are jamming. They are right past the 45 day period so that isn't an option. My G&G high caps feed flawlessly. I guess my next option is to break them down and try to do the above mentioned. Might try to stretch the spring a little. Other wise I have 9 really nice paper weights.

#6 hellcat

hellcat

    Enthusiast

  • Members
  • PipPip
  • 130 posts
  • Gender:Male
  • Location:west palm beach florida
  • Interests:Airsoft, Football, Nascar, Guns, cars/trucks, and of women in yoga pants!!
  • Country:

Posted 10 March 2014 - 05:48 PM

I have had the same issue with my K120 mag's, but that was after one year of use. What I did was take out the spring and bb follower, clean everything real good and when I reassembled them I coated the bb follower with a lite coat of 80 weight silicone shock oil.....every one of them have been working flawless since. I own 14 of them.

#7 rgjeep

rgjeep

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Lake Elsinore
  • Interests:Airsoft, milsim, four wheeling and real steel
  • Country:

Posted 10 March 2014 - 08:37 PM

I will break them all down and lube and dremel them. I am not a fan of high caps that is why I went with the midcaps and figured the kwa mids should have no problem in the kwa mod 2.

#8 hellcat

hellcat

    Enthusiast

  • Members
  • PipPip
  • 130 posts
  • Gender:Male
  • Location:west palm beach florida
  • Interests:Airsoft, Football, Nascar, Guns, cars/trucks, and of women in yoga pants!!
  • Country:

Posted 11 March 2014 - 01:36 PM

View Postrgjeep, on 10 March 2014 - 08:37 PM, said:

I will break them all down and lube and dremel them. I am not a fan of high caps that is why I went with the midcaps and figured the kwa mids should have no problem in the kwa mod 2.
Just be very careful what you take a dremel tool too....I suggest you use a hand file for the retainer pin.

#9 rgjeep

rgjeep

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Lake Elsinore
  • Interests:Airsoft, milsim, four wheeling and real steel
  • Country:

Posted 11 March 2014 - 03:35 PM

I will go easy on them. Lol

#10 Rain Man

Rain Man

    Enthusiast

  • Members
  • PipPip
  • 109 posts
  • Gender:Male
  • Interests:Airsoft (obviously). Gaming. Baseball. Fantasy Football. Skiing
  • Country:

Posted 14 March 2014 - 06:08 AM

View Posthellcat, on 10 March 2014 - 05:48 PM, said:

I have had the same issue with my K120 mag's, but that was after one year of use. What I did was take out the spring and bb follower, clean everything real good and when I reassembled them I coated the bb follower with a lite coat of 80 weight silicone shock oil.....every one of them have been working flawless since. I own 14 of them.
Exactly what worked for me! Just be sure to clean the track well after you grease it so the bb's won't bring up excess lube with it and soak the bucking, thus ruining it.

#11 rgjeep

rgjeep

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Lake Elsinore
  • Interests:Airsoft, milsim, four wheeling and real steel
  • Country:

Posted 15 March 2014 - 03:51 PM

so i got into all the mags and so far mixed results its about 50/50. great on full auto but hit and miss on semi.....i am perplexed.......

#12 hellcat

hellcat

    Enthusiast

  • Members
  • PipPip
  • 130 posts
  • Gender:Male
  • Location:west palm beach florida
  • Interests:Airsoft, Football, Nascar, Guns, cars/trucks, and of women in yoga pants!!
  • Country:

Posted 16 March 2014 - 01:45 PM

I just thought of something else you should look at......I have now had 2 of my friends KWA M4 have miss feeding issues in the past 6 weeks....here is what I found to correct the problems...Hopup unit was not properly lining up with the feed ramp...Left/Right miss alignment. The way I found this is as soon as the miss feeding began, I flipped the gun over and pulled out the mag. then I would single shot and watch the bb's to see if they would  fall into the hop up chamber....would not fall...I would then use a pin punch and put a small amount of pressure on the bb's and I could feel the resistance. I removed all bb's and then used a flashlight too look down the feed ramp. At this point I was able to see a lip on the side of the hop unit.One gun I just replaced the hop up body, the second gun I just took some 400 grit sand paper to the side of the hop up unit no longer interfered with feeding.

And just for the hell of it I checked both of my own guns and both had the same similar lips when looking down the feed ramp, but did not have feeding issues, but for the hell of it I took those out and sanded down the same way.

#13 rgjeep

rgjeep

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Lake Elsinore
  • Interests:Airsoft, milsim, four wheeling and real steel
  • Country:

Posted 16 March 2014 - 03:53 PM

Interesting I thought there hellcat. I will take a look. The only thing that throws me is that the high feed perfectly every time. It's just the high caps that are giving me issue.

#14 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,509 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 16 March 2014 - 04:17 PM

View Postrgjeep, on 16 March 2014 - 03:53 PM, said:

Interesting I thought there hellcat. I will take a look. The only thing that throws me is that the high feed perfectly every time. It's just the high caps that are giving me issue.
What?

#15 hellcat

hellcat

    Enthusiast

  • Members
  • PipPip
  • 130 posts
  • Gender:Male
  • Location:west palm beach florida
  • Interests:Airsoft, Football, Nascar, Guns, cars/trucks, and of women in yoga pants!!
  • Country:

Posted 16 March 2014 - 04:45 PM

View Postrgjeep, on 16 March 2014 - 03:53 PM, said:

Interesting I thought there hellcat. I will take a look. The only thing that throws me is that the high feed perfectly every time. It's just the high caps that are giving me issue.

When you use High cap. mags. you wind that spring up really tight and that pushes the bb's easier.

#16 rgjeep

rgjeep

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Lake Elsinore
  • Interests:Airsoft, milsim, four wheeling and real steel
  • Country:

Posted 18 March 2014 - 05:37 AM

Ahhhh that makes sense. Well guess I will start trying some other mags and test out what works best.

#17 caelanbd

caelanbd

    Enthusiast

  • Members
  • PipPip
  • 32 posts
  • Country:

Posted 19 March 2014 - 05:41 PM

Go with a Lonex Flashmag lol I love the freaking thing. Nothing like having all 400 bbs feed flawlessly without having to spin a wheel lol. Just 4-5 pulls of a cord and shazam!

#18 StealthTaskForce

StealthTaskForce

    Enthusiast

  • Members
  • PipPip
  • 132 posts
  • Gender:Male
  • Location:Tampa
  • Interests:Airsoft, Paintball, Sports, My girlfriend, Knives and Real Steel
  • Country:

Posted 19 March 2014 - 06:20 PM

View Postcaelanbd, on 19 March 2014 - 05:41 PM, said:

Go with a Lonex Flashmag lol I love the freaking thing. Nothing like having all 400 bbs feed flawlessly without having to spin a wheel lol. Just 4-5 pulls of a cord and shazam!
Do you have a link to those magazines? Cuz I like the sound of those too lol

#19 StealthTaskForce

StealthTaskForce

    Enthusiast

  • Members
  • PipPip
  • 132 posts
  • Gender:Male
  • Location:Tampa
  • Interests:Airsoft, Paintball, Sports, My girlfriend, Knives and Real Steel
  • Country:

Posted 19 March 2014 - 06:44 PM

I actually found one, and I looked at about 5 different sites, with Evike being the cheapest from 4 dollars, all the way to 12 bucks cheaper.
http://www.evike.com/products/33418/

#20 rgjeep

rgjeep

    Newbie

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Lake Elsinore
  • Interests:Airsoft, milsim, four wheeling and real steel
  • Country:

Posted 22 March 2014 - 04:34 PM

Sorry I jacked that one up, I meant to say only the high caps will work hellcat. I think I might try the lonex flash mags.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users