Jump to content


M11A1 Problem


  • Please log in to reply
3 replies to this topic

#1 PvtSkittles12

PvtSkittles12

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 04 October 2009 - 09:58 AM

I bought a KWA M11A1 not too long ago. I love this little gun. Recently, I've been having major problems with it. One day I went to shoot it, but all of the gas sprayed out of the bolt and the barrel. This kept happening numerous times. Then after I gave up on shooting it, I went to release the gas out of the magazine. I pressed the button, but then the rubber gas seal flies off land lands in my neighbor's yard(I luckily found it). Does anyone know what I could do to fix this?

#2 Guest_Box Goblin_*

Guest_Box Goblin_*
  • Guests

Posted 06 October 2009 - 10:32 AM

i have same probkem when I buy new gun so i supergrue the each corner of rubber seal into metal lip.

#3 sickbeast

sickbeast

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 21 March 2010 - 06:49 AM

Dunno if anyone else has had this problem but that happened to me exactly too.

I tried to superglue too but it didnt really hold since I had lubed up the whole gun.
Do you think it might be a gas problem? The gas being too powerful and blowing out the seal?
I just used regular Top Gas

To make it worse, the plastic ramp on the bolt that feeds the BBs from the mag into the barrel broke too :(

View PostBox Goblin, on 06 October 2009 - 10:32 AM, said:

i have same probkem when I buy new gun so i supergrue the each corner of rubber seal into metal lip.


#4 Spiggy

Spiggy

    Member

  • Members
  • PipPipPipPip
  • 2,136 posts
  • Gender:Male
  • Location:City of Industry
  • Country:

Posted 22 March 2010 - 03:13 PM

If your ramp is plastic, I've got bad news for you.

It's probably not a KWA.

Cylinder on the other hand could be your problem, sounds like your gun has all the old parts that have since been phased and replaced.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users