Jump to content


Kmp9 Now Just A Very Nice Springer.


  • Please log in to reply
10 replies to this topic

#1 2good2betrue77

2good2betrue77

    Newbie

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Country:

Posted 26 May 2012 - 08:22 PM

Hey everyone, I have been lurking around these KWA forums for quite some time, but I ran into a problem with my KWA that I just cannot seem to solve.

To put it shortly, my KMP9 is a very accurate, loud, and powerful springer. I need to pull back on the charging handle after every shot if I want to shoot a bb out of the airsoft gun. I found a video on youtube of the exact same problem I am having with my KMP9.



I disassembled the airsoft gun and discovered that around when the hammer reset block comes into contact or surpasses the hammer, that the friction between the bolt and the lower receiver increases dramatically. I believe that this high amount of friction is what prevents the airsoft gun from cycling fully and resetting the hammer. Now I cleaned and lubed the gun and payed special attention to areas where the bolt makes contact with any other surface, but the problem still remains even though everything looks fine to me.

I just want  to make it clear that I am comfortable disassembling the KMP9 and would prefer not to send it in to KWA (my M9 PTP has been there for the last two to three weeks and I miss it very much. I would tear up if I had to play multiple games without my KMP9, aka my favorite gun in my airsoft arsenal.)

Now a little info about the gun and the conditions in which it broke...

-I got it in mid-February.
-Originally ran propane, but after breaking two gas cylinder chambers and the breech base, I switched to green gas and have not had any problems until now (made the switch sometime in March.)
-I filed down the sharp edges of the bolt catch so I do not believe this can be the cause of the high friction.
-The gun was well maintained and I had cleaned and lubed it after every game.
-Temperature was in the 90's. The gun barely passed chrono shooting at 398 fps with .20s.
-Gun worked fine until the problem occurred and showed no prior sign of breaking down.

Thanks in advance for any help. I look forward to your responses.

Edited by 2good2betrue77, 26 May 2012 - 08:26 PM.


#2 niko_gpsy

niko_gpsy

    What's a Warranty?

  • Super Moderator
  • PipPipPipPip
  • 5,875 posts
  • Gender:Male
  • Location:Atlanta, GA
  • Interests:Keeping those damn squirrels from putting their filthy little paws on my peaches in my backyard. Oh, Yes. It's not just a hobby, its a passion!!
  • Country:

Posted 29 May 2012 - 04:59 PM

Have you checked the jet/rocket valve to make sure it's seated correctly?  Sounds to me that the bolt is not moving from not having enough gas pass through the cylinder.  It can be either the jet nozzle or the release valve on the magazine.

#3 vilerk

vilerk

    Newbie

  • Members
  • Pip
  • 15 posts

Posted 30 May 2012 - 06:32 PM

Check if the hammer snapped at its axle.

#4 2good2betrue77

2good2betrue77

    Newbie

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Country:

Posted 30 May 2012 - 09:29 PM

View Postniko_gpsy, on 29 May 2012 - 04:59 PM, said:

Have you checked the jet/rocket valve to make sure it's seated correctly?  Sounds to me that the bolt is not moving from not having enough gas pass through the cylinder.  It can be either the jet nozzle or the release valve on the magazine.

The Jet valve appears to be set in place correctly so I don't believe that is the problem.

View Postvilerk, on 30 May 2012 - 06:32 PM, said:

Check if the hammer snapped at its axle.

I took the KMP9 apart and I believe this could actually be the problem. I don't see an actual crack but the hammer is pretty wobbly sitting inside the gun. I read a post from Dobey somewhere on this forum and some of the problems he described seemed to fit for my gun as well.

I appreciate your help guys. Guess the next question is if their is a nice guide on taking out the trigger/hammer assembly out of the lower receiver. The only KWA GBB I ever had to take apart down to the trigger was a MKII in order to replace a missing firing pin so I wouldn't say I have experience in that regard haha.

Again, I appreciate the help.

EDIT: Found the link to the post I was talking about.

http://kwausa.com/fo...?showtopic=6290

Edited by 2good2betrue77, 30 May 2012 - 09:41 PM.


#5 Fox

Fox

    Newbie

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Riverside, CA
  • Interests:Roughneck Airsoft Detachment
  • Country:

Posted 25 June 2012 - 06:54 PM

Thanks for the link mine just recenlty broke on the axle as well. How do you get the hammer assembely out?

#6 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,509 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 25 June 2012 - 07:33 PM

Saw this same issue this weekend. Snapped hammer axle

#7 thatstevecharacter

thatstevecharacter

    Newbie

  • Members
  • Pip
  • 4 posts
  • Country:

Posted 17 July 2012 - 01:52 PM

View Post2good2betrue77, on 26 May 2012 - 08:22 PM, said:

Hey everyone, I have been lurking around these KWA forums for quite some time, but I ran into a problem with my KWA that I just cannot seem to solve. To put it shortly, my KMP9 is a very accurate, loud, and powerful springer. I need to pull back on the charging handle after every shot if I want to shoot a bb out of the airsoft gun. I found a video on youtube of the exact same problem I am having with my KMP9. I disassembled the airsoft gun and discovered that around when the hammer reset block comes into contact or surpasses the hammer, that the friction between the bolt and the lower receiver increases dramatically. I believe that this high amount of friction is what prevents the airsoft gun from cycling fully and resetting the hammer. Now I cleaned and lubed the gun and payed special attention to areas where the bolt makes contact with any other surface, but the problem still remains even though everything looks fine to me. I just want to make it clear that I am comfortable disassembling the KMP9 and would prefer not to send it in to KWA (my M9 PTP has been there for the last two to three weeks and I miss it very much. I would tear up if I had to play multiple games without my KMP9, aka my favorite gun in my airsoft arsenal.) Now a little info about the gun and the conditions in which it broke... -I got it in mid-February. -Originally ran propane, but after breaking two gas cylinder chambers and the breech base, I switched to green gas and have not had any problems until now (made the switch sometime in March.) -I filed down the sharp edges of the bolt catch so I do not believe this can be the cause of the high friction. -The gun was well maintained and I had cleaned and lubed it after every game. -Temperature was in the 90's. The gun barely passed chrono shooting at 398 fps with .20s. -Gun worked fine until the problem occurred and showed no prior sign of breaking down. Thanks in advance for any help. I look forward to your responses.

Mine is doing the exact same thing, and I just made a post about it. Except i can shoot maybe 3-5 shots, and one burst if on auto before i have to keep racking it. Sometimes racking it again still doesn't allow me to get a shot off.

#8 thatstevecharacter

thatstevecharacter

    Newbie

  • Members
  • Pip
  • 4 posts
  • Country:

Posted 17 July 2012 - 02:43 PM

Just talked to a friend of mine at KWA, He said part 162, the disconnector spring is most likely weakened, causing, or attributing to the issue. He said he sees it all the time.

#9 Dirt Bag

Dirt Bag

    Enthusiast

  • Members
  • PipPip
  • 162 posts
  • Gender:Male
  • Location:California
  • Country:

Posted 17 July 2012 - 05:58 PM

Try lubing the mag valve. Probably not the problem, but I've fixed a similar issue on a pistol by just putting a good amount of silicone oil on the mag valve. It doesn't hurt to try.

#10 niko_gpsy

niko_gpsy

    What's a Warranty?

  • Super Moderator
  • PipPipPipPip
  • 5,875 posts
  • Gender:Male
  • Location:Atlanta, GA
  • Interests:Keeping those damn squirrels from putting their filthy little paws on my peaches in my backyard. Oh, Yes. It's not just a hobby, its a passion!!
  • Country:

Posted 18 July 2012 - 04:09 AM

View Postgcw360, on 25 June 2012 - 07:33 PM, said:

Saw this same issue this weekend. Snapped hammer axle
Yup.

#11 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,509 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 18 July 2012 - 07:01 PM

View Postniko_gpsy, on 18 July 2012 - 04:09 AM, said:

Yup.
Ditto!




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users