Jump to content


New Polyer Magazine feeding Problem


  • Please log in to reply
6 replies to this topic

#1 YankTE88

YankTE88

    Newbie

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:West De Pere, WI
  • Interests:Football
    Airsoft
    U.S.M.C.
  • Country:

Posted 04 July 2013 - 04:07 PM

Hey guys, I have  a KWA KM4 and recently purchased the newer polymer magazines (here's the link if you don't know: http://www.airsoftgi...oducts_id=10882) Anyways, the magazines for some reason don't feed, and the only reason I can think of is when I lock them fully into the mag well they still have a little room where I can push them up a little farther into the mag well. Does anybody know how to solve this problem/or what the real problem is? Any help would be appreciated, thanks guys!

#2 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,714 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 04 July 2013 - 10:09 PM

View PostYankTE88, on 04 July 2013 - 04:07 PM, said:

Hey guys, I have  a KWA KM4 and recently purchased the newer polymer magazines (here's the link if you don't know: http://www.airsoftgi...oducts_id=10882) Anyways, the magazines for some reason don't feed, and the only reason I can think of is when I lock them fully into the mag well they still have a little room where I can push them up a little farther into the mag well. Does anybody know how to solve this problem/or what the real problem is? Any help would be appreciated, thanks guys!
Sorry to hear you are having issues.  Is the magazine release assembly tightened?  What gun are you using them in, what mags had you been using, what BB's are you using?  Can  you describe the type of miss-feed and was the gun feeding with other mags?  Lastly, have you added Ranger Plates to the mags or altered them in any way?  Sorry for all the questions, but it should help us give you an answer.

#3 Chuck S

Chuck S

    Guru

  • Members
  • PipPipPipPip
  • 1,335 posts
  • Gender:Male
  • Location:Cleveland, Ohio
  • Country:

Posted 05 July 2013 - 04:39 AM

They all show this problem?

Unless you got a bad batch (I assume you bought a 6-pack) I'm thinking it's your gun as my samples work perfectly in my KM4 and a Brand-X Tavor I recently purchased.  Barring bad magazines the mag catch is the first suspect.  Out of spec BBs second.

-- Chuck

#4 niko_gpsy

niko_gpsy

    What's a Warranty?

  • Super Moderator
  • PipPipPipPip
  • 5,884 posts
  • Gender:Male
  • Location:Atlanta, GA
  • Interests:Keeping those damn squirrels from putting their filthy little paws on my peaches in my backyard. Oh, Yes. It's not just a hobby, its a passion!!
  • Country:

Posted 05 July 2013 - 08:49 AM

I am guessing the mag release need to be tightened.

#5 YankTE88

YankTE88

    Newbie

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:West De Pere, WI
  • Interests:Football
    Airsoft
    U.S.M.C.
  • Country:

Posted 05 July 2013 - 10:13 AM

View Postgcw360, on 04 July 2013 - 10:09 PM, said:

Sorry to hear you are having issues.  Is the magazine release assembly tightened?  What gun are you using them in, what mags had you been using, what BB's are you using?  Can  you describe the type of miss-feed and was the gun feeding with other mags?  Lastly, have you added Ranger Plates to the mags or altered them in any way?  Sorry for all the questions, but it should help us give you an answer.

View PostChuck S, on 05 July 2013 - 04:39 AM, said:

They all show this problem?

Unless you got a bad batch (I assume you bought a 6-pack) I'm thinking it's your gun as my samples work perfectly in my KM4 and a Brand-X Tavor I recently purchased.  Barring bad magazines the mag catch is the first suspect.  Out of spec BBs second.

-- Chuck
I'm using them in my KM4 RIS, before I've been using AimTop High Caps with Evike pro grade .25's and Javelin .2's. I haven't changed my mags at all, the only thing I did was break them in by loading/unloading them about 4 times each before 1st use. When using the AimTops they all fed pretty much perfect during a game, only a few dry fires in between, the mid caps however would shoot one round then just dry-fire after that.

#6 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,714 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 05 July 2013 - 04:49 PM

View PostYankTE88, on 05 July 2013 - 10:13 AM, said:

I'm using them in my KM4 RIS, before I've been using AimTop High Caps with Evike pro grade .25's and Javelin .2's. I haven't changed my mags at all, the only thing I did was break them in by loading/unloading them about 4 times each before 1st use. When using the AimTops they all fed pretty much perfect during a game, only a few dry fires in between, the mid caps however would shoot one round then just dry-fire after that.
How full are you filling them?  Sometimes you can have feeding issues if you overfill the mags.  Try like 60 rounds, just a s a test, and see what happens.

#7 guyevr4

guyevr4

    Newbie

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Country:

Posted 07 July 2013 - 03:03 PM

Try loosening or tightening the screws that hold the lower hop up feeder, mine were over tightened and it put slight pressure on the feedramp causing misfeeds and jams




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users