Jump to content


Kwa M93R Ns2 Problem Prevention

M93r Ns2 Semi-auto problem Prevention Fix How to Help

  • Please log in to reply
19 replies to this topic

#1 darrelleman

darrelleman

    Newbie

  • Members
  • Pip
  • 15 posts
  • Country:

Posted 09 May 2012 - 06:44 PM

Hey guys so I'm new to these forums so I hope this post doesn't break any rules.

I just bought the M93r Ns2 because I loved the style and all the functions of it also! So clearly I was very disappointed to find out that there is a common problem going on with the M93r. As far as I understand it the gun will eventually stop working on semi-auto and either only fire full or burst, or even worse only fires full auto on all functions.

Because I am not going to shell out about $60 to get this gun fixed when or if it breaks(Even though from what i hear this is expected with this gun) considering I just spent over $200 on this gun and a spare mag.( that's a years worth of savings for me). So now to the question; How can I prevent this gun from breaking? Or if it does break is there an easy way to fix it?

I will be so disappointed in this gun and KWA if this gun breaks. I mean come on this is KWA, I shouldn't be spending my time worrying about how to prevent a common breakage I should be shooting. And also $200 is a lot for an airsoft gun and my parents went out on a limb and trusted me on this one, if it breaks i doubt that will happen again.

#2 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,562 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 09 May 2012 - 07:12 PM

Topic moved to appropriate section.

#3 darrelleman

darrelleman

    Newbie

  • Members
  • Pip
  • 15 posts
  • Country:

Posted 10 May 2012 - 01:00 PM

View Postgcw360, on 09 May 2012 - 07:12 PM, said:

Topic moved to appropriate section.
Thank you, anybody have anything?

#4 VictorNica

VictorNica

    Customer Service Specialist

  • KWA Staff
  • PipPip
  • 112 posts
  • Gender:Male
  • Country:

Posted 10 May 2012 - 02:02 PM

Welcome to the forums Darrelleman and congratulations on your new purchase! The forums are here to help users with any problems they might help and technical support. We distribute thousands of products all over the country but we do not usually read posts from them because they are not seeking technical support.

We have seen several M93Rs have an issue shooting on the wrong setting however this issue does not affect most of the products sold. We do our best to make sure every gun we sell is working properly and consistently which is why we regularly evaluate each model to see how we can improve and avoid any problems in the future.

Your gun has yet to have a problem so I would not worry about it breaking. As I said before most of the guns sold do not have a problem. If something does happen don't hesitate to contact on our Help Desk.

#5 ransackedsnake7

ransackedsnake7

    Enthusiast

  • Members
  • PipPip
  • 71 posts
  • Gender:Male
  • Country:

Posted 10 May 2012 - 04:29 PM

Darelleman Here is some advice to making any airsoft gun last a long time
1.  CLEAN YOUR GUN  most people who have problems with their guns don't clean them, check out the vids on gbb maintenance on this website  
2.  LUBE YOUR GUN a well oiled gun will last longer, don't use spray silicon oil or get any oil inside your inner barrel, i ruined my first ATP hop up bucking by putting oil in the barrel.  Also dont go overkill with the lube, the video will cover this
3.  USE GREEN GAS  you put the money down for a good gun don't cheap out on the gas, you wouldn't put diesel in a ferrari would you.  
propane just causes problems.
You don't have to lube your gun every day or clean it every day.  i usually clean and lube all my guns after a day at the field and their fine.  
I think you will really like your m93r, there's a few at my field it sucks being shot three times in a row :)

Edited by ransackedsnake7, 10 May 2012 - 04:30 PM.


#6 Outlaw1995

Outlaw1995

    Guru

  • Members
  • PipPipPipPip
  • 1,713 posts
  • Gender:Male
  • Interests:Acting, Piano, Films, Theatre, Firearms, Knives, Airsoft
  • Country:

Posted 10 May 2012 - 06:18 PM

Follow ransackedsnake7's tips and you should be good to go darrelleman.

#7 Billy1788

Billy1788

    Newbie

  • Members
  • Pip
  • 26 posts
  • Country:

Posted 28 June 2012 - 04:55 AM

I have the same question about kwa M93r.

Besides ransackedsnake7's COMMON tips, are there any other SPECIAL tips to prevent the issue?

Darrelleman, how about your M93r now?

#8 MultipleParadox

MultipleParadox

    Enthusiast

  • Members
  • PipPip
  • 138 posts
  • Gender:Male
  • Country:

Posted 28 June 2012 - 05:18 AM

Do what RansackedSnake said

Clean and Lube after any extended usage.

I had mine for a year or so and it still is working great (I hope) in the hands of it's new owner. I never had issues with the selector.

The problem you're more likely to encounter is the nozzle breaking (part 6 if my memory's correct)

To prevent, clean and lube! But it will most probably happen at sone point. I consider that part a "consumable", so you might want to buy an extra nozzle now, and maybe a set springs just in case.

Also, don't abuse the full auto. For one, the real gun is not full auto. And it does put a lot more stress on the internals. So use with moderation. 3Burst shouldn't be as prohibitive. In all case, single shot is more precise and the gun cycles so fast that you can still have a good rate of fire and more precision using single shot.

As for propane, using it will void warranty. So at least don't use it until your warranty has ended. I personally used propane exclusively without any issues, but I wouldn't recommend it unless you understand all the implications an risks. You might not have the same results and damage your gun. So it really is up to your discretion.

Enjoy! It's a great gun to shoot! I know i will miss mine :P

#9 Billy1788

Billy1788

    Newbie

  • Members
  • Pip
  • 26 posts
  • Country:

Posted 28 June 2012 - 08:38 AM

Very helpful, Thanks!

Does it mean that full auto function will cause this issue easily? Or say, useing it in semi or 3burst mode will prevent the issue effectively?

#10 MultipleParadox

MultipleParadox

    Enthusiast

  • Members
  • PipPip
  • 138 posts
  • Gender:Male
  • Country:

Posted 28 June 2012 - 08:55 AM

Prevent, not really
Reduce the odds, definitely!

#11 Billy1788

Billy1788

    Newbie

  • Members
  • Pip
  • 26 posts
  • Country:

Posted 28 June 2012 - 09:28 AM

Thanks again!

If there were illustration guidance to demostrate how to fix this typical issue, it would be very helpful to all KWA M93R fans!

Edited by Billy1788, 29 June 2012 - 07:04 AM.


#12 Billy1788

Billy1788

    Newbie

  • Members
  • Pip
  • 26 posts
  • Country:

Posted 28 June 2012 - 01:47 PM

Also is it necessary to take off the RIGHT grip panel where all the fire control components are located, clean all parts and re-lube ?

#13 MultipleParadox

MultipleParadox

    Enthusiast

  • Members
  • PipPip
  • 138 posts
  • Gender:Male
  • Country:

Posted 29 June 2012 - 04:35 AM

I don't think it is
Unless, if like me you let yours fall from you holster in the sand and there's sand everywhere inside the gun, incliding the grips. Then yes :P

I mean, it's all about common sense guys, there's no voodoo or sorcery involved

#14 Standard4130

Standard4130

    Enthusiast

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Location:TX
  • Interests:Current Interest are.......Machining/Manufacturing, Airsoft or any projectile shooting device, Aviation, Motorcycling, Fishing, Photography, Music........And so many more. (I'm lazy and will add later....LOL)
  • Country:

Posted 04 July 2012 - 12:18 AM

Since KWA seems to be ignoring this particular problem I'll take up their slack for free.......If you are having this problem click on my user name and E-mail me. I'll be more than happy to talk you through fixing this problem yourself....... I'm testing some other options too.

#15 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,562 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 04 July 2012 - 04:50 AM

View PostStandard4130, on 04 July 2012 - 12:18 AM, said:

Since KWA seems to be ignoring this particular problem I'll take up their slack for free.......If you are having this problem click on my user name and E-mail me. I'll be more than happy to talk you through fixing this problem yourself....... I'm testing some other options too.
Why not share the answer here for all of us to see?

#16 darrelleman

darrelleman

    Newbie

  • Members
  • Pip
  • 15 posts
  • Country:

Posted 20 July 2012 - 02:48 PM

Mine is working great so far. I rarely use full auto and 3 round burst and I lube and clean with care every other week with moderate use. I've run into a problem with the hop up that seems like nobody knows how to fix but thats for another topic!

#17 Standard4130

Standard4130

    Enthusiast

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Location:TX
  • Interests:Current Interest are.......Machining/Manufacturing, Airsoft or any projectile shooting device, Aviation, Motorcycling, Fishing, Photography, Music........And so many more. (I'm lazy and will add later....LOL)
  • Country:

Posted 23 July 2012 - 11:23 AM

Yes, clean and lube just like you would with a real firearm....(using lube that appropriate for airgun use). What's up with your hop up?

#18 Standard4130

Standard4130

    Enthusiast

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Location:TX
  • Interests:Current Interest are.......Machining/Manufacturing, Airsoft or any projectile shooting device, Aviation, Motorcycling, Fishing, Photography, Music........And so many more. (I'm lazy and will add later....LOL)
  • Country:

Posted 23 July 2012 - 11:37 AM

View Postdarrelleman, on 20 July 2012 - 02:48 PM, said:

Mine is working great so far. I rarely use full auto and 3 round burst and I lube and clean with care every other week with moderate use. I've run into a problem with the hop up that seems like nobody knows how to fix but thats for another topic!

darrelleman, Found your hop up post and replied there.........

#19 Miner

Miner

    Newbie

  • Members
  • Pip
  • 1 posts
  • Country:

Posted 04 September 2012 - 01:03 AM

I also having problems with my M93R.  I only went through a few magazines and now the single fire mode does not work.  The gun shoots full auto when the selector is in the single fire mode.  You would think that if KWA was aware of this problem they would have fixed it.  I sent service ticket in and am waiting to see if KWA will fix the problem with no charge or if it will cost me toget the gun to operate properly.  I will follow up when I hear back from KWA.

#20 Neurotrauma

Neurotrauma

    Newbie

  • Members
  • Pip
  • 8 posts
  • Country:

Posted 01 November 2012 - 11:15 AM

I used mine only for plinking so far, I had my first one break 2nd mag out of the box and only shoot full auto on semi. I sent it back to my canadian retailer and they sent me a new one. This one lasted for maybe 20 mags worth, just now it broke yet again. I only used the full auto function like two-3 times in 20 mags, mostly semi and a little 3 round burst, so to confirm, NOT USING FULL AUTO WILL NOT STOP IT FROM BREAKING.

Im super pissed, this gun is my baby and I just ordered a 48 rd mag... guess I gotta open the guts up and fix it myself cuz this is going to keep happening.





Also tagged with one or more of these keywords: M93r, Ns2, Semi-auto problem, Prevention, Fix, How to, Help

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users