Jump to content


KWA M19 shooting issues

Disconnector

  • Please log in to reply
27 replies to this topic

#1 Spector

Spector

    Enthusiast

  • Members
  • PipPip
  • 42 posts
  • Gender:Male
  • Location:Maine
  • Interests:Airsoft!, Camping, Offroading, Atv's, Anything with wheels
  • Country:

Posted 21 March 2013 - 06:34 AM

Hello I'am new to this forum and also to a KWA product. I am having some trouble with my M19 and am wondering if anyone has some info that could help me get it up and shooting again before airsoft season.

The Problem:
Shoots maybe one round in the entire mag then releases all gas, also with no recoil (slide not pushing back).

After doing research I bought some parts that I thought would hopefully stop this from occurring the pieces I had purchased were a new gas valve for the bottom of the mag, a new mag release due to the original being plastic and over time shaving down loosening the mag, and a Disconnector (which mine was missing with the the disconnector spring). I purchased the disconnector but not the spring due to it being sold out in every online store I've checked. What I want to know are three things: (1). Any ideas as to what could be causing the main problem other than the Disconnector, (2). What is the purpose of the disconnector, (3).Any Ideas on where to buy or find a spring part no. 82.

Any help I will be very thankful for I've worked very hard ontrying to get this working and am not giving up on it just yet.

#2 Huntsman82

Huntsman82

    Enthusiast

  • Members
  • PipPip
  • 128 posts
  • Gender:Male
  • Location:Houston, Texas
  • Interests:Airsoft, Rock Climbing, RS Shooting and Tactics Courses
  • Country:

Posted 21 March 2013 - 07:07 AM

I want to say that replacing the hammer spring can help with this issue. I'm not 100% sure though.

#3 Spector

Spector

    Enthusiast

  • Members
  • PipPip
  • 42 posts
  • Gender:Male
  • Location:Maine
  • Interests:Airsoft!, Camping, Offroading, Atv's, Anything with wheels
  • Country:

Posted 21 March 2013 - 07:18 AM

It might be but its unlikley, I've disassembled the trigger assembly before and the hammer spring appeared to be fine.

#4 Airsoftguy

Airsoftguy

    Enthusiast

  • Members
  • PipPip
  • 90 posts
  • Gender:Male
  • Location:Los Angeles
  • Interests:FPS limit? What's that?
  • Country:

Posted 21 March 2013 - 08:35 AM

Check out these videos this guy gives some good tips on M series pistols failing and what parts he needed to fix these problems. Although this is for the M18c, the problem you explained above exists in almost every M series pistol.
I THINK in one of these 3 part videos he shows what he did to fix the problem you were having. Sorry I'm not sure which of the 3 he addressed this problem in.

1st part:


2nd part:

Edited by Airsoftguy, 21 March 2013 - 08:39 AM.


#5 Airsoftguy

Airsoftguy

    Enthusiast

  • Members
  • PipPip
  • 90 posts
  • Gender:Male
  • Location:Los Angeles
  • Interests:FPS limit? What's that?
  • Country:

Posted 21 March 2013 - 08:40 AM

3rd part:


Hope this helped.

#6 Spector

Spector

    Enthusiast

  • Members
  • PipPip
  • 42 posts
  • Gender:Male
  • Location:Maine
  • Interests:Airsoft!, Camping, Offroading, Atv's, Anything with wheels
  • Country:

Posted 21 March 2013 - 09:02 AM

Lol in process may have screwed my glock over just put slide on now hammer is'nt getting cocked so now cant remove the slide yes saw first video but this is the hammer not the part he was talking about could use some help asap!!!

#7 Airsoftguy

Airsoftguy

    Enthusiast

  • Members
  • PipPip
  • 90 posts
  • Gender:Male
  • Location:Los Angeles
  • Interests:FPS limit? What's that?
  • Country:

Posted 21 March 2013 - 09:13 AM

Get a small rod of some sort and cock the hammer by pushing down on it from the back of the pistol. Where the plastic piece is. Shown in the first video. This should allow you to remove your slide. In the video he does cock the hammer manually with a small flat head screwdriver. The hammer is probably the only thing not letting your slide come off. This happened to me once.

Edited by Airsoftguy, 21 March 2013 - 09:17 AM.


#8 Spector

Spector

    Enthusiast

  • Members
  • PipPip
  • 42 posts
  • Gender:Male
  • Location:Maine
  • Interests:Airsoft!, Camping, Offroading, Atv's, Anything with wheels
  • Country:

Posted 21 March 2013 - 09:18 AM

Its ok everyone I got the slide off :clap: Anyways what I did notice that a spring part no.79 was not attached to part 78 and is partially loose and only connectedto the bottom part any ideas?

#9 Airsoftguy

Airsoftguy

    Enthusiast

  • Members
  • PipPip
  • 90 posts
  • Gender:Male
  • Location:Los Angeles
  • Interests:FPS limit? What's that?
  • Country:

Posted 21 March 2013 - 09:25 AM

Yes that spring has to be connected to part no 78!. Part no 78 is the firing pin. The spring part no 79 has be attached to it in order to return the firing pin to its original position. Without that spring the firing pin will just strike the flow valve on the magazine and won't return causing all gas to be released.

This might be your problem after all. Try attaching that spring and let us know if that worked.

#10 Spector

Spector

    Enthusiast

  • Members
  • PipPip
  • 42 posts
  • Gender:Male
  • Location:Maine
  • Interests:Airsoft!, Camping, Offroading, Atv's, Anything with wheels
  • Country:

Posted 21 March 2013 - 09:32 AM

Thankyou!! this is the problem after putting two and two together I figured out that the disconnector (part 81) locks the firing pin now the only problem is where to find part 82!!! which is the spring I've been looking everywhere for but to no prevail :cry: so if anyonehas a spare or knows where to get one it would be very appreciated!

#11 Airsoftguy

Airsoftguy

    Enthusiast

  • Members
  • PipPip
  • 90 posts
  • Gender:Male
  • Location:Los Angeles
  • Interests:FPS limit? What's that?
  • Country:

Posted 21 March 2013 - 04:52 PM

I would contact the KWA pro shop. You'll have to call them they might have some parts.

#12 Spector

Spector

    Enthusiast

  • Members
  • PipPip
  • 42 posts
  • Gender:Male
  • Location:Maine
  • Interests:Airsoft!, Camping, Offroading, Atv's, Anything with wheels
  • Country:

Posted 21 March 2013 - 05:09 PM

I did they said they had none :cry: do you have a KWA Airsoftguy?

Edited by Spector, 21 March 2013 - 05:11 PM.


#13 Outlaw1995

Outlaw1995

    Guru

  • Members
  • PipPipPipPip
  • 1,713 posts
  • Gender:Male
  • Interests:Acting, Piano, Films, Theatre, Firearms, Knives, Airsoft
  • Country:

Posted 23 March 2013 - 09:31 AM

This link says they are out of stock.
(http://store.kwausa....eset-1-1-4.aspx)

Since the ATP is relatively similar to the m-series, I'd suggest finding the pieces used in the ATP to fix your gun... I believe these are the springs you are talking about?

http://store.kwausa....esetspring.aspx
http://store.kwausa....esetspring.aspx
http://store.kwausa....turnspring.aspx

Give KWA another call and see if they have these "ATP" parts.

#14 Spector

Spector

    Enthusiast

  • Members
  • PipPip
  • 42 posts
  • Gender:Male
  • Location:Maine
  • Interests:Airsoft!, Camping, Offroading, Atv's, Anything with wheels
  • Country:

Posted 23 March 2013 - 09:34 AM

This is actually really funny I realized this last night too, and just bought part 74 for the ATP crossing my fingers it works with my M19.

#15 Spector

Spector

    Enthusiast

  • Members
  • PipPip
  • 42 posts
  • Gender:Male
  • Location:Maine
  • Interests:Airsoft!, Camping, Offroading, Atv's, Anything with wheels
  • Country:

Posted 27 March 2013 - 02:33 PM

Update!

Okay so far I got the parts I was missing and reassembled the trigger assembly everything is where it should be but with little improvement.

Problem:
Can shoot 1 to 2 rounds before all gas is gone there is little to no recoil when shooting and sometimes the recoil spring dislocates make the slide strugle to move.

I am using propane for testing. Im curiuos if itcould be the air nozzle or the two springs part no.23 which are slightly bent. Also could the recoil spring be upgraded causing the slide to struggle?

#16 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,560 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 30 March 2013 - 05:43 AM

View PostSpector, on 27 March 2013 - 02:33 PM, said:

Update!

Okay so far I got the parts I was missing and reassembled the trigger assembly everything is where it should be but with little improvement.

Problem:
Can shoot 1 to 2 rounds before all gas is gone there is little to no recoil when shooting and sometimes the recoil spring dislocates make the slide strugle to move.

I am using propane for testing. Im curiuos if itcould be the air nozzle or the two springs part no.23 which are slightly bent. Also could the recoil spring be upgraded causing the slide to struggle?
If the recoils spring has been upgraded, that could contribute to the issue of not fully cycling.  Do you have a stock spring?

#17 Spector

Spector

    Enthusiast

  • Members
  • PipPip
  • 42 posts
  • Gender:Male
  • Location:Maine
  • Interests:Airsoft!, Camping, Offroading, Atv's, Anything with wheels
  • Country:

Posted 03 April 2013 - 05:11 PM

View Postgcw360, on 30 March 2013 - 05:43 AM, said:

If the recoils spring has been upgraded, that could contribute to the issue of not fully cycling.  Do you have a stock spring?

I'm not positive if it is or not is there a way to tell?

#18 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,560 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 03 April 2013 - 07:13 PM

View PostSpector, on 03 April 2013 - 05:11 PM, said:

I'm not positive if it is or not is there a way to tell?
Not without the OEM for comparison.

#19 Spector

Spector

    Enthusiast

  • Members
  • PipPip
  • 42 posts
  • Gender:Male
  • Location:Maine
  • Interests:Airsoft!, Camping, Offroading, Atv's, Anything with wheels
  • Country:

Posted 04 April 2013 - 02:03 AM

View Postgcw360, on 03 April 2013 - 07:13 PM, said:

Not without the OEM for comparison.

Would taking a photo help?

#20 gcw360

gcw360

    Supreme Guru

  • Super Moderator
  • PipPipPipPip
  • 11,560 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Airsoft (Especially repair and customizing), Fly Fishing, Fossils (Especially Dino), Snakes, Photography
  • Country:

Posted 04 April 2013 - 03:45 PM

View PostSpector, on 04 April 2013 - 02:03 AM, said:

Would taking a photo help?
No guarantees but it's worth a try.  If you post a picture, I can compare it to my OEM M19 return spring.





Also tagged with one or more of these keywords: Disconnector

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users